[TriLUG] RedHat 8.0 / IPTables / GRE packets?

prhodes at vdsinc.com prhodes at vdsinc.com
Tue Dec 10 14:27:13 EST 2002

Question for you network / linux guru's...

I'm using RedHat 8.0, and trying to connect to a poptop server.  The poptop
is also an iptables based firewall, providing masquerading for the rest of
network, from the cable modem...

The problem is, I can't establish a connection to the poptop server from my
I have (I think) narrowed the problem down to pptpd not receiving the
config-req response
from the client.  This appears to be because the GRE packets aren't getting

I have a line in my iptables script which is supposed to allow GRE

iptables -A INPUT -p 47 -i eth0 -s 0/0 -j ACCEPT

but it still doesn't work.  Curiously enough, even if I try to log incoming
GRE packets

iptables -A INPUT -p 47 -i eth0 -s 0/0 -j LOG

I don't see anything in the log from an attempted connection.  However, if
I run
tcpdump on eth0 and watch the raw packets when I try a connection, I see
GRE packets come in.  It's almost like iptables isn't recognizing the GRE

Does anybody know if there's anything else special I need to do to
make this work?  If so, please do tell....


Phillip Rhodes
Application Designer
Voice Data Solutions
919-571-4300 x225
prhodes at vdsinc.com

Those who are willing to sacrifice essential liberties for a little order,
will lose both and deserve neither. - Benjamin Franklin

This country, with its institutions, belongs to the people who inhabit it.
Whenever they shall grow weary of the existing government, they can
exercise their constitutional right of amending it, or exercise their
revolutionary right to overthrow it.  - Abraham Lincoln

No citizen shall be denied the right to bear arms, if as a last resort, to
protect themselves from tyranny in Government. - Thomas Jefferson

More information about the TriLUG mailing list