[TriLUG] Network Guru Needed

Jon Carnes jonc at nc.rr.com
Tue Sep 7 13:40:33 EDT 2004


On Tue, 2004-09-07 at 13:02, Brian Henning wrote:
> That reminds me..  I think I read something about that a while ago but long
> since forgot what or where..  Suppose I want to establish a bit of physical
> redundancy between some switches by having more than one cable between them.
> That this causes packet floods makes sense to me, the loop is obvious..  My
> question is, what does one need to make that stop, and retain the
> redundancy?
> 
> Cheers,
> ~Brian
> 

Really quickly... For Managed Cisco switches you build a special
Port-channel and then add interfaces as needed to it.:

! On Switch 1
!
interface Port-channel10
 switchport trunk encapsulation dot1q
 switchport mode trunk
 no ip address
!
interface FastEthernet0/12
 description Trunk to Switch 2
 switchport trunk encapsulation dot1q
 switchport mode trunk
 no ip address
 duplex full
 speed 100
 no cdp enable
 channel-group 10 mode desirable
!
interface FastEthernet0/24
 description Trunk to Switch 2
 switchport trunk encapsulation dot1q
 switchport mode trunk
 no ip address
 duplex full
 speed 100
 no cdp enable
 channel-group 10 mode desirable
!
interface Vlan10
 ip address 10.150.1.252 255.255.255.0
 no ip redirects
 standby 10 ip 10.150.1.254
 standby 10 timers 3 7
 standby 10 priority 110
 standby 10 preempt


! On Switch 2
!
interface Port-channel10
 switchport trunk encapsulation dot1q
 switchport mode trunk
 no ip address
!
interface FastEthernet0/12
 description To Switch 1
 switchport trunk encapsulation dot1q
 switchport mode trunk
 no ip address
 duplex full
 speed 100
 no cdp enable
 channel-group 10 mode desirable
!
interface FastEthernet0/24
 description To Switch 1
 switchport trunk encapsulation dot1q
 switchport mode trunk
 no ip address
 duplex full
 speed 100
 no cdp enable
 channel-group 10 mode desirable
!
interface Vlan10
 ip address 10.150.1.253 255.255.255.0
 no ip redirects
 standby 10 ip 10.150.1.254
 standby 10 timers 3 7
 standby 10 preempt

===

Not only do these switches have redundant port connections, but they are
also set to take over for each other should one fail.  :-)

Jon





More information about the TriLUG mailing list