[TriLUG] LVM InitRAMfs

Seva Adari oddissyus at gmail.com
Thu May 3 12:39:29 EDT 2012

Hi Brian,

I have not tried lvm on Debian, but last time I did an lvm install on
Ubuntu, it was tricky. I could n't install it directly from the install CD.
I don't know how different Debian is from Ubuntu, but following is
what I did on Ubuntu.

1.  Boot into livecd
2. Open terminal and Install the lvm package
3. Load the kernel module dm-mod via modprobe
4. Manually partition the disk using fdisk
    Boot can't be part of lvm. Make sure that boot is on a separate
    partition and the rest per your needs. Swap can be part of lvm
5. Let the OS know of created partitions: partprobe
6. Create /boot file system using mkfs on your first partition
7. Next create your lvm partitions (including swap)
   Create lvm physical (pvcreate), group (vgcreate) and logical
8. Create file systems on your lvm partitions using mkfs
9. Now on the livecd desktop you will see a 'install' icon, click that
    to start install
10. When you come to disk partitioning select manual and choose
   the partitions you made for appropriate mount points
11. Continue with install until the final step
   'Do you want to continue to use Live CD or Restart'
13. Your installed system has no lvm package installed, so you need
  to do that before your restart and that may be the problem you are
  experiencing. Here is what you do from a terminal:
  sudo chroot /target
  aptitutde update
  aptitude install lvm2
14. Reboot and it should recognize boot and recognize lvm

The install I did was couple years ago and I hope it has gotten better
since then.

On Tue, May 1, 2012 at 9:25 PM, Brian McCullough <bdmc at bdmcc-us.com> wrote:
> Folks,
> I am in a bit of a conundrum.
> I have just finished installing a Debian Squeeze system, using LVM to
> configure the drive, and everything seemed to install correctly.
> Unfortunately, when I boot the machine, it stops and says that it can't
> find the filesystems.
> If I issue "lvm vgscan" and "lvm vgchange -a y" at the command prompt (
> initramfs: ) and then Ctrl-D, the boot continues successfully.
> I have tried "update-initramfs -u" several times, with no improvement.
> I then added a two line file to
> /etc/initramfs-tools/scripts/local-premount, with those two lines. No
> help.  I then moved the script file to
> /etc/initramfs-tools/scripts/init-premount, and got some different
> messages, but ultimately, it still does not boot correctly.
> Any suggestions?
> Thanks,
> Brian
> --
> This message was sent to: oddissyus at gmail.com <oddissyus at gmail.com>
> To unsubscribe, send a blank message to trilug-leave at trilug.org from that address.
> TriLUG mailing list : http://www.trilug.org/mailman/listinfo/trilug
> Unsubscribe or edit options on the web  : http://www.trilug.org/mailman/options/trilug/oddissyus%40gmail.com
> TriLUG FAQ          : http://www.trilug.org/wiki/Frequently_Asked_Questions

More information about the TriLUG mailing list