17:34:37 <isharacomix> #startmeeting
17:34:37 <Tribot> Meeting started Tue Mar 24 17:34:37 2015 UTC.  The chair is isharacomix. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:34:37 <Tribot> Useful Commands: #action #agreed #help #info #idea #link #topic.
17:34:47 <isharacomix> #chairs isharacomix whippythellama mhrivnak jackhill
17:35:07 <isharacomix> #topic March Hack Night
17:35:20 <isharacomix> Sorry I couldn't make it to the hack night. How was it?
17:35:42 <whippythellama> despite the weather and the scary "our parking lot might collapse and kill everyone" email, we still had 5 ppl there  :)
17:35:43 <mhrivnak> likewise.
17:36:04 <isharacomix> Anything cool get worked on?
17:36:09 <whippythellama> jackhill led the discussion on future infrastructure directions
17:36:57 <whippythellama> we all agreed that we should develop ansible, puppet, chef, etc configs to define things
17:37:00 <jackhill> and that was positive. Now I need to put up a "first draft" to attract other hackers
17:37:13 <whippythellama> something we can keep in source control
17:37:14 <isharacomix> i hope we only choose one of the three. :)
17:37:36 <whippythellama> yeah, i think we all leaned toward ansible, at least to start
17:37:49 <whippythellama> but definitely - only one  :)
17:37:56 <mhrivnak> sounds good!
17:38:00 <whippythellama> we also spent some time on backups
17:38:11 <isharacomix> Sounds very productive.
17:38:12 <whippythellama> i think i've found a way that we can keep a lot more
17:38:25 <whippythellama> i still need to cook up a proof of concept
17:38:45 <isharacomix> If we're keeping things in source control, where are we keeping it? Github? Gitlab?
17:38:50 <whippythellama> #action whippythellama hack up a proof of concept for the iterative backup approach started in hack night
17:38:57 <jackhill> there is a cron job that running and doing the rsync now
17:38:59 <jackhill> whippythellama: cool
17:39:00 <whippythellama> still undecided, isharacomix
17:39:12 <jackhill> #jackhill "first draft" of new infrastructure
17:39:21 <isharacomix> :)
17:39:43 <whippythellama> Jmainguy has tried to reach out to the "maintainter" of the trilug github repo
17:39:49 <isharacomix> hehe
17:39:50 <whippythellama> no news yet on that front that i've heard
17:39:53 <mhrivnak> who is that?
17:39:56 <jackhill> er #action jackhill "first draft" of new infrastructure.
17:40:11 <whippythellama> i'd need to look it up on the steering wiki, mhrivnak
17:40:23 <mhrivnak> jschornick has most of the commits.
17:40:28 <mhrivnak> alpo has 2
17:40:32 <whippythellama> ncsu student (former student?)
17:40:48 <isharacomix> Are we talking about a single repo or an organization?
17:40:56 <jackhill> Speaking of infrastructue, any word from NCSU-LUG about a server exchange?
17:40:56 <mhrivnak> ericleasemorgan has 1 commit.
17:41:04 <mhrivnak> I'm looking at the only repo under github.com/trilug/
17:41:09 <isharacomix> ok
17:41:11 <mhrivnak> https://github.com/trilug/member_tool/
17:41:27 <whippythellama> mhrivnak: that's the one
17:41:35 <isharacomix> jackhill, we just need to bug leafstorm about that. :)
17:41:41 <whippythellama> there's a page on the wiki mentioning who to talk to
17:41:47 <jackhill> It should be easy to get stuff out of there with git clone (I'm not convinced I care about the issues or pull requests for that repo)
17:41:49 <whippythellama> i haven't  heard back from leafstorm yet
17:42:08 <whippythellama> jackhill: yeah, but it would be nice for trilug to own the 'trilug' github repo  :)
17:42:13 <whippythellama> er, account
17:42:18 <jackhill> whippythellama: cool. I'm in no rush, but was just curious of the status update.
17:42:26 <whippythellama> sure
17:42:48 <isharacomix> Good luck working that front. That will be important, I think.
17:43:03 <whippythellama> agreed
17:43:05 <isharacomix> Anything else before moving on
17:43:06 <isharacomix> ?
17:43:22 <jackhill> not from me
17:43:24 <whippythellama> #action whippythellama follow up with Jmainguy on github account ownership
17:43:34 <whippythellama> just so we don't lose that
17:43:37 <isharacomix> #topic April meeting
17:43:54 <whippythellama> triangle devops was a panel
17:43:58 <isharacomix> GIven the topics at the last hack night, automation seems appropriate for a subject.  :)
17:44:06 <isharacomix> whippythellama: any leads?
17:44:07 <whippythellama> so it wasn't a prepared talk, per se
17:44:38 <whippythellama> i have spoken to one of the panelists, and it sounds like he might have a presentation on implementing docker
17:44:50 <whippythellama> i've emailed him, but i haven't heard back yet
17:44:59 <isharacomix> We've recently had a docker talk, haven't we?
17:45:05 <whippythellama> not sure
17:45:07 <jackhill> whippythellama: did you hear back from Kevin?
17:45:07 <mhrivnak> I think it's been over a year.
17:45:14 <jackhill> and docker is changing so fast
17:45:17 <mhrivnak> But, I would recommend waiting a short bit on docker.
17:45:24 <isharacomix> just under. it was last may :)
17:45:32 <mhrivnak> agreed with jackhill . Everything in docker is changing right now. :)
17:45:39 <isharacomix> interesting
17:45:43 <whippythellama> ok
17:45:50 <whippythellama> but we have NO topic for april
17:46:00 <jackhill> whippythellama: have you heard back from Kevin?
17:46:01 <whippythellama> so i'd rather have a semi-recent topic than dead air
17:46:13 <whippythellama> no, jackhill - i haven't followed up on that
17:46:19 <isharacomix> my offer to talk about versioned puppet in github is still on the table.
17:46:21 <whippythellama> #action whippythellama follow up with kevin on his talks
17:46:27 <whippythellama> do it
17:46:32 <isharacomix> haha
17:46:35 <whippythellama> if it's ready, isharacomix - let's do that  :)
17:46:47 <whippythellama> not kidding - it does sound interesting
17:46:49 <isharacomix> i've been working on it for the past three months.
17:46:52 <mhrivnak> http://trilug.org/2014-03-13/docker
17:47:00 <mhrivnak> ^ March 2014 meeting on docker
17:47:01 <whippythellama> mhrivnak - thanks
17:47:04 <isharacomix> mhrivnak: oops, you're right. :D
17:47:05 <whippythellama> lol
17:47:22 <whippythellama> "it's time for our annual spring docker presentation!"
17:47:24 <whippythellama> :)
17:47:24 <mhrivnak> and an April 5 docker hack day
17:47:42 <isharacomix> i think we can spin a talk like this and make the conversation follow the ideas we have for trilug itself
17:48:11 <whippythellama> "this" == docker, or "this" == puppet+github?
17:48:19 <isharacomix> puppet+github
17:48:25 <whippythellama> agreed  :)
17:48:42 <whippythellama> so how confident are you in having it ready for april, isharacomix?
17:48:46 <isharacomix> i can do it
17:48:53 <whippythellama> i'm in favor
17:48:56 <mhrivnak> me too
17:49:00 <isharacomix> i can also try to secure cumulus sponsorship
17:49:08 <whippythellama> double woot!
17:49:45 <isharacomix> how's the rest of the pipeline - are we still in contact with our potential speakers?
17:49:49 <whippythellama> yes
17:50:03 <jackhill> yes
17:50:07 <isharacomix> #action isharacomix write an abstract and talk for "living the devops"
17:50:55 <whippythellama> my speaker pipeline is the one fellow from the triangle devops panel, kevin's two potential talks, and *maybe* something from carolinacon
17:51:03 <isharacomix> Sounds solid
17:51:19 <isharacomix> we've also got someone interested in a free your phone prezo?
17:51:28 <whippythellama> i need to re-review the speakers - not all of them are appropriate, local, or linux-related
17:51:32 <mhrivnak> FWIW, I'm doing a talk at a red hat conference this summer called "Docker for Developers" that I could preview to trilug at some point.
17:51:34 <whippythellama> sweet
17:51:50 <whippythellama> excellent, mhrivnak - would *love* to see that
17:52:07 <mhrivnak> focusing on how docker can be useful for a single developer with their laptop, and forgetting completely about kubernetes and big deployment voodoo
17:52:27 <whippythellama> yeah, that would be really valuable
17:52:28 <isharacomix> Does someone want to review the steering list to catch up with all of the talk ideas pitched by members?
17:52:35 <mhrivnak> So, that could be its own thing, or I could pair with the other guy doing docker stuff.
17:53:05 <whippythellama> mhrivnak: i'll loop you in once i hear back from him
17:53:14 <mhrivnak> great.
17:53:46 <whippythellama> i still have an action to put up the wish list as well, isharacomix
17:53:53 <whippythellama> carry-over from last meeting - on trello
17:54:05 <isharacomix> whippythellama: awesome, that's good to hear
17:54:35 <isharacomix> #topic General business
17:54:57 <jackhill> When is billf back?
17:55:02 <isharacomix> I'll schedule the F2F this week, so start looking at your calendars
17:55:11 <isharacomix> mid april?
17:55:17 <isharacomix> I think he's missing the april talk too
17:55:18 <jackhill> @isharacomix++
17:55:23 <whippythellama> one thing on my mind is the elections - i've got one interested party, and another that i need to ask
17:55:29 <isharacomix> awesome!
17:55:34 <isharacomix> We also need volunteers
17:55:36 <jackhill> oh, right, I need to ask mine
17:55:39 <isharacomix> to help with the election
17:55:41 <whippythellama> agreed
17:56:42 <isharacomix> any other orders of business folks want to bring up?
17:56:55 <whippythellama> trilug-business vs trilug-steering
17:57:15 <isharacomix> I'm more than happy to put all meetings on trilug-business unless otherwise necessary
17:57:17 <jackhill> My proposal was to use -business for everything except when it needs to be private
17:57:28 <whippythellama> i'm okay with this
17:57:39 <isharacomix> I propose that all meetings start on trilug-business, and are moved to private channel by a motion from the SC.
17:57:47 <jackhill> +1
17:57:54 <whippythellama> there's not a lot of back-room stuff that goes on anyway  :)
17:57:55 <mhrivnak> I'm happy either way.
17:57:58 <jackhill> (wait, there's a meetbot command for this)
17:58:13 <isharacomix> does meetbot follow robert's rules? :)
17:58:29 <jackhill> #agreed that all meetings start on trilug-business, and are moved to private channel by a motion from the SC.
17:58:38 <isharacomix> i like it
17:58:51 <whippythellama> ok, here it is
17:58:52 <jackhill> I think that will make a nice thing in the minutes :)
17:58:59 <isharacomix> whippythellama: are the meetbot logs saved in directories based on the channel name?
17:59:06 <whippythellama> isharacomix: yep
17:59:18 <isharacomix> OK. Maybe find a way to reconcile them so that we don't lose the minutes
17:59:41 <whippythellama> isharacomix: that shouldn't be too terribly hard, but yeah
17:59:58 <isharacomix> We're at time. Any last words?
18:00:09 <jackhill> no
18:00:10 <whippythellama> i think i'm good for now
18:00:42 <isharacomix> #endmeeting