17:01:21 <whippythellama> #startmeeting
17:01:21 <Tribot> Meeting started Tue Sep 15 17:01:21 2015 UTC.  The chair is whippythellama. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:01:21 <Tribot> Useful Commands: #action #agreed #help #info #idea #link #topic.
17:01:28 <whippythellama> #chairs mhrivnak leafstorm whippythellama eronel jackhill
17:01:33 <whippythellama> (just in case)
17:01:41 <whippythellama> #topic September Meeting recap
17:01:55 <whippythellama> i'm working on the video render
17:02:05 <leafstorm> I think it went well - we ended up with a great panel
17:02:24 <mhrivnak> agreed. Thanks for everyone's help finding panelists!
17:02:27 <whippythellama> i finally got the speaker portion of it to render, now i'm going to try to get the panel stitched on as well
17:02:32 <mhrivnak> did we get an attendance count?
17:02:48 <whippythellama> i agree - great topic, and a great panel
17:02:52 <whippythellama> doh!
17:02:55 <whippythellama> no, i did not :(
17:03:22 <whippythellama> i would ballpark it at mid-40's to low-50's
17:03:41 <whippythellama> but that's just a guess
17:04:04 <leafstorm> I didn't hear of any building access problems
17:04:13 <mhrivnak> pizza consumption suggest either 50+ or a hungrier-than-usual crowd. :)
17:04:13 <leafstorm> cleanup went well, the main problem was disposing of the leftovers
17:04:26 <leafstorm> we had like 3 pizzas left over at the end
17:04:36 <whippythellama> hmm, ok
17:04:51 <mhrivnak> oh. They've let us leave them in the refrigerator in the past.
17:04:52 <leafstorm> I left the sodas in the breakroom
17:05:06 <leafstorm> I couldn't find the fridge so I just wrote "<3 TriLUG" on the sodas and put them on the counter
17:05:14 <whippythellama> qqx, Jmainguy - you guys are muted; if you need to bring anything up, just msg one of us to voice you
17:05:25 <whippythellama> sounds like a good way to go
17:05:40 <leafstorm> also, Calvin and his son suggested getting vegan pizza for next week
17:05:53 <whippythellama> hmm
17:05:58 <leafstorm> mhrivnak said he thinks it's a good idea, but doesn't know if Marco's can fulfill
17:06:04 <leafstorm> s/next week/next meeting/
17:06:11 <whippythellama> i would want to ask the group about that, honestly
17:06:17 <whippythellama> i don't know how much demand there would be
17:06:21 <whippythellama> if there is, i'm all for it
17:06:38 <whippythellama> i just don't want to order a pizza that only one or two folks would eat
17:06:38 <mhrivnak> I agree that we should poll for interest.
17:06:47 <leafstorm> OK, should I prepare a Google form or something?
17:06:58 <leafstorm> eh, we probably don't need a Google form, I'll just email the list
17:07:02 <whippythellama> sure, or just an email to the group
17:07:05 <whippythellama> heh - that :)
17:07:08 <leafstorm> #action leafstorm poll the membership for vegan pizza support
17:07:25 <whippythellama> if we get enough folks saying they'd eat it, we can certainly start ordering one
17:08:13 <whippythellama> i'll post the video once i can successfully render it; the way i recorded this way seems to be giving ffdiaporama fits with the rendering
17:08:34 <whippythellama> i kept getting black screens with just audio
17:08:51 <whippythellama> anything else from last week?
17:09:03 <leafstorm> I can't think of anything right now
17:09:10 <whippythellama> ok, cool
17:09:21 <whippythellama> #topic September Hack Night
17:09:44 <whippythellama> thank you for putting up the post and emailing the announcement, leafstorm
17:09:50 <leafstorm> you're welcome
17:09:58 <leafstorm> I'm currently planning to be there, but I might be late
17:10:02 <whippythellama> ok, cool
17:10:08 <leafstorm> I'll also probably not be able to make most hack nights in the future
17:10:08 <whippythellama> i won't be - got that dinner
17:10:09 <mhrivnak> I won't be able to make it.
17:10:24 <whippythellama> eronel and jackhill indicated that they would be there
17:10:50 <whippythellama> everyone see jackhill's email regarding goals?
17:10:59 <mhrivnak> yep. sounds good.
17:11:02 <leafstorm> deploy one VM (ideally pilot)?
17:11:08 <whippythellama> yep
17:11:17 <leafstorm> something I'd add: *document* how to deploy a new VM and add it to the network
17:11:23 <leafstorm> bonus points if it's automated
17:11:24 <whippythellama> +1
17:11:30 <mhrivnak> +1
17:11:31 <whippythellama> i would say it MUST be automated
17:11:47 <leafstorm> well, maybe not setting up the guest OS
17:12:09 <leafstorm> but if we create a new VM, setting up the firewall rules, any HAProxy, etc. should be automated
17:12:41 <Jmainguy> yes, we should have things in config mgmt and version control, preferably git and ansible, but I am biased
17:12:48 <Jmainguy> but, documentation is definitly a must
17:12:52 <whippythellama> +1000000 for git and ansible
17:13:02 <Jmainguy> we should all count on getting hit by a bus, or losing interest, so it needs to be maintainable
17:13:08 <whippythellama> exactly
17:13:23 <whippythellama> the "lottery bus" factor
17:13:55 <whippythellama> how to set up a new trilug vm that does "foo"?  run the "setupfoo" script
17:13:59 <whippythellama> or the like
17:14:11 <Jmainguy> yup, that would be cool
17:14:11 <leafstorm> ansible-playbook foo.yml # :-P
17:14:24 <leafstorm> Jmainguy: do you have any playbooks we could base off of?
17:14:25 <mhrivnak> agreed with all, but we should save these implementation details for thursday.
17:14:29 <whippythellama> i wrap my ansible playbooks in shell scripts to simplify syntax  :)
17:14:39 <leafstorm> obviously there would need to be porting from CentOS to Debian, but we can probs handle that
17:14:44 <Jmainguy> leafstorm: I do not have any atm, but I will write some gladly for this project
17:14:51 <whippythellama> mhrivnak: agreed - this is precisely what we should do on hack night
17:14:53 <leafstorm> that would be appreciated
17:15:01 <Jmainguy> I want to understand the arhitecutre we are aiming for, before I start working on it
17:15:20 <leafstorm> I think it's basically what you suggested - KVM + internal network + port forwarding & haproxy
17:15:23 <mhrivnak> Jmainguy, ack. I suggest an email thread.
17:15:24 <whippythellama> Jmainguy: are you going to be online or in person on thursday?
17:15:36 <Jmainguy> whippythellama: I will try to be in person, if not I will definitly be online
17:15:41 <whippythellama> ok, cool
17:15:49 <Jmainguy> mhrivnak: makes sense
17:15:57 <whippythellama> i think we've covered all we need to on this for the steering meeting
17:16:23 <whippythellama> #topic StartSSL Certificates
17:16:34 <leafstorm> who gets the email for those?
17:16:41 <whippythellama> figure hack night was a good segue into this :)
17:16:49 <whippythellama> honestly, i don't know
17:16:50 <leafstorm> did Bill hardcode himself?
17:16:57 <leafstorm> (er, billf)
17:17:00 <whippythellama> but i liked your idea of starting a trilug-sysadmin list
17:17:12 <billf> I'm not sure why I get the emails
17:17:29 <billf> I am probably still in the aliases file
17:17:30 <whippythellama> billf: do they go to you directly, or to a list of which you are a member?
17:17:44 <mhrivnak> I get them.
17:17:52 <mhrivnak> I think there's an alias on pilot.
17:18:02 <mhrivnak> emails go to postmaster@trilug.org
17:18:40 <whippythellama> ok, so that should probably change
17:18:57 <leafstorm> there are lots of aliases in /etc/aliases
17:19:11 <leafstorm> webmaster@ and certs@ are forwarded directly to isharacomix@, so that's fun
17:19:15 <billf> should add something about the aliases file to the handover doc
17:19:23 <whippythellama> agreed, billf
17:19:28 <leafstorm> or just manage that using mailing lists, so that we never have to change /etc/aliases again
17:19:45 <mhrivnak> https://steering.trilug.org/wiki/index.php/NewOfficerProcess
17:19:52 <mhrivnak> lines 2 and 3
17:19:53 <whippythellama> leafstorm: that was my thought
17:20:19 <whippythellama> mhrivnak: thank you
17:20:35 <leafstorm> right now everything is forwarded to root@, which is forwarded to sysadmin@, which is forwarded to a list of people
17:20:53 <mhrivnak> the document isn't explicit about what to do, but I seem to recall that the aliases file has some reasonable inline documentation.
17:20:53 <leafstorm> porter, billf, mhrivnak, isharacomix, jackhill, and whippythellama
17:21:02 <leafstorm> yeah, it makes sense once you read it
17:21:04 <whippythellama> does anyone have bandwidth to take point on re-wrangling the aliases and lists at the moment?  if not, i'll take it for now
17:21:17 <leafstorm> I'd appreciate you taking it
17:21:51 <leafstorm> there's a bunch of services forwarding to Jeff Schornick, who is that?
17:21:59 <whippythellama> #action whippythellama take point on re-working the sysadmin-type aliases and lists
17:22:21 <billf> jeff was a previous SC member
17:22:23 <whippythellama> #action whippythellama take point on SSL cert renewal
17:23:11 <whippythellama> ok, i'll get those things started
17:23:18 <whippythellama> let's move on
17:23:25 <whippythellama> #topic October Meeting
17:23:40 <leafstorm> sorry for not following up with Dr. Parnin, BTW
17:23:49 <whippythellama> i emailed him last night
17:24:07 <whippythellama> i'm hoping he's still available
17:24:40 <leafstorm> worst comes to worst, I have a set of systemd slides prepared
17:24:46 <whippythellama> if so, we should be good; if not, sean alexandre had expressed an interest in presenting on linux server security
17:24:50 <leafstorm> but this would be the 2nd "me" talk in a year and the 2nd systemd talk in the year
17:25:33 <whippythellama> let's give it a few days and see if Dr Parnin works out
17:25:58 <whippythellama> only one other thing
17:26:19 <leafstorm> did we ever confirm Jim Salter for November?
17:26:27 <whippythellama> leafstorm: would you mind putting up a placeholder announcement after hack night?
17:26:28 <leafstorm> or was that just a suggestion from Todd Lewis?
17:26:44 <leafstorm> #action leafstorm put up a placeholder announcement for Oct meeting
17:26:46 <whippythellama> leafstorm: i will confirm him - he slipped out before i could talk to him last thursday
17:26:57 <whippythellama> #action whippythellama confirm Jim Salter for November
17:27:02 <leafstorm> make sure you find out what his topic is first.
17:27:21 <whippythellama> no - i figured i'd leave it a surprise  ;)
17:27:37 <whippythellama> trilug, november - macrame and you!
17:28:10 <leafstorm> or worse, macromedia
17:28:12 <whippythellama> lol
17:28:18 <whippythellama> ok, two minute warning
17:28:23 <whippythellama> #topic General Business
17:28:32 <whippythellama> wow - actually got through the whole agenda this week
17:28:34 <whippythellama> woot
17:28:51 <whippythellama> one other thing on my mind is the holiday party in december
17:28:53 <leafstorm> jackhill mentioned GirlDevelopIt wanted to join forces for Ada Day
17:29:24 <whippythellama> yeah, that's awesome  :)
17:29:24 <leafstorm> also...do we still want to try and have a picnic this fall, or just wait for the holiday party?
17:29:24 <leafstorm> also...do we still want to try and have a picnic this fall, or just wait for the holiday party?
17:29:27 <leafstorm> temperatures never stopped being ridiculous :-P
17:29:57 <whippythellama> i'd be up for it, probably in october
17:30:11 <mhrivnak> I'm happy either way.
17:30:18 <whippythellama> jeremy davis showed me some pics of a promising park in apex
17:30:26 <leafstorm> yeah, I saw those pics too
17:30:33 <leafstorm> I'm not sure if they work for quite what we're envisioning though
17:30:35 <mhrivnak> long-term I think it has more appeal as a mid-year social event to balance the holiday event, but for the first one, I think October would be fine.
17:30:39 <leafstorm> not enough covered space for demos
17:30:47 <leafstorm> so, put it on next week's agenda?
17:31:03 <whippythellama> mhrivnak: agreed on the timeframe, it's the mid-year weather that was the concern  :)
17:31:10 <whippythellama> leafstorm: agreed
17:31:15 <leafstorm> then again I don't expect that to ever get any better
17:31:34 * mhrivnak needs to go
17:31:40 <whippythellama> yeah, we're at time
17:31:41 <leafstorm> close up then?
17:31:47 <whippythellama> yep - thanks, all!
17:31:50 <whippythellama> #endmeeting