17:01:45 <whippythellama> #startmeeting
17:01:45 <Tribot> Meeting started Tue May 31 17:01:45 2016 UTC.  The chair is whippythellama. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:01:45 <Tribot> Useful Commands: #action #agreed #help #info #idea #link #topic.
17:01:53 <whippythellama> #chair qqx stmiller mhrivnak whippythellama
17:01:53 <Tribot> Current chairs: mhrivnak qqx stmiller whippythellama
17:02:06 <whippythellama> #topic Additional Agenda Items
17:02:15 <whippythellama> anyone have anything they'd like to cover?
17:02:25 <qqx> not me
17:02:25 <whippythellama> mhrivnak: your meetup findings, perhaps?
17:02:42 <mhrivnak> Optional. I sent an email a few minutes ago.
17:02:52 <mhrivnak> We can handle discussion there, or do it here if time allows.
17:02:58 <whippythellama> yep, saw that :)
17:02:59 <stmiller> Curious about that Frontier location - looks great.
17:03:04 <whippythellama> indeed
17:03:27 <whippythellama> ok, so nothing oh-fish-ul, then
17:03:33 <whippythellama> "as time allows"
17:03:43 <whippythellama> #topic June Meeting
17:04:00 <whippythellama> everyone still planning on attending, everything set, etc?
17:04:12 <mhrivnak> yep
17:04:16 <qqx> yes
17:04:18 <stmiller> Yes. All set on the bandwidth side
17:04:24 <whippythellama> ok, cool
17:04:41 <whippythellama> i figured as much, but wanted to check just in case :)
17:04:48 <whippythellama> #topic June Hack Night
17:05:11 <whippythellama> jeremy emailed frontier last night about hosting the june hack night there
17:05:34 <whippythellama> he cc'ed me, but i haven't seen anything back yet
17:05:51 <whippythellama> so hopefully that will work
17:06:19 <mhrivnak> Sounds good.
17:06:19 <whippythellama> i still need to re-mail the list about alternate locations, tho
17:06:20 <stmiller> Cool. Is that also the anticipated July regular meeting spot?
17:06:28 <stmiller> err location
17:06:35 <whippythellama> that's what we're hoping, yes
17:06:48 <whippythellama> #action whippythellama email the list about alternative hack night locations
17:07:21 <whippythellama> plan right now i believe is to have the june hack night be a deferred ansible-focused hack night
17:07:43 <mhrivnak> Ah. Is jtate coming?
17:07:52 <whippythellama> i was just about to bring that up
17:08:05 <whippythellama> we should ask him at the june meeting
17:08:18 <whippythellama> ...or before, whichever  :)
17:08:38 <mhrivnak> Or sooner, so he can put it on his calendar. :)
17:08:50 <whippythellama> yeah, that would be better
17:09:27 <whippythellama> do any of you know if you're planning on attending?
17:09:37 <whippythellama> i believe i will be able to
17:09:45 <mhrivnak> not sure yet.
17:10:24 <qqx> I'm planning to be there.
17:10:28 <whippythellama> excellent!
17:10:43 <stmiller> I'm a maybe, if needed
17:10:45 <mhrivnak> I'll probably need to skip, because my pilot certificate check ride is 2 days later, and I'll be studying like crazy.
17:11:01 <whippythellama> heh - as far as reasons go, that's a good one  ;)
17:11:26 <whippythellama> stmiller: gotcha; you have attended a good number of them  :)
17:12:01 <whippythellama> i'll ping jtate and see if he'll be available
17:12:11 <whippythellama> #action whippythellama ping jtate about june hack night
17:12:24 <whippythellama> anything else on this for now?
17:12:45 <mhrivnak> nothing here
17:13:15 <whippythellama> ok, taking silence as assent... :)
17:13:20 <whippythellama> #topic Static Site
17:13:33 <whippythellama> stmiller: last i checked, the static version of the site was looking pretty good
17:13:44 <whippythellama> got the nav links on the side and everything
17:13:55 <whippythellama> is that jeckyl?
17:13:58 <stmiller> Yeah. I think now I'm in the customize sort of phase.
17:14:25 <stmiller> It is jekyll. It will not run on ubuntu 12.04 (needs ruby 2.x), but can run in a little ruby env thing
17:14:39 <whippythellama> aaah. ok
17:14:53 <mhrivnak> can we get away with only needing ruby at build time, but not at run time?
17:15:14 <qqx> Yes, ruby would only be needed during the build
17:15:14 <whippythellama> good point
17:15:20 <whippythellama> oh, excellent
17:15:31 <qqx> So, that wouldn't need to be done on pilot
17:15:31 <whippythellama> then yeah, we could just use rbenv or the like to build it then
17:15:34 <stmiller> Ah yeah oh snap
17:15:51 <mhrivnak> Or build them on another machine even if necessary.
17:15:58 <whippythellama> sure
17:16:20 <whippythellama> but we might be able to do it with a headless build user that has rbenv (or similar) set up
17:16:27 <whippythellama> that should be able to go anywhere
17:16:33 <mhrivnak> Sounds good.
17:16:51 <qqx> Yeah, a dedicated user with an rbenv setup should work fine.
17:17:12 <whippythellama> and it would be portable and not tied to any particular sc member's acct
17:17:15 <qqx> Could even set up a git hook to have that done automatically when we push to a repo.
17:17:22 <whippythellama> (in case of the lottery bus problem)
17:17:28 <whippythellama> qqx: exactly!
17:18:29 <whippythellama> that might make a nice hack night project
17:18:43 <whippythellama> ansible-ize the setup of a static site build user
17:19:22 <mhrivnak> good point.
17:19:32 <stmiller> I don't want this to get too complicated
17:19:44 <whippythellama> not complicated at all
17:19:58 <whippythellama> whatever we end up with needs to have automation around it
17:20:06 <whippythellama> nothing over-the-top or anything
17:20:14 <stmiller> Yeah gotcha
17:20:27 <whippythellama> but there are already too many processes that we have to go look up on the wiki, or on the file system, or ask alan for, etc
17:21:07 <whippythellama> not that this eliminates that entirely, but the more we have codified in scripts and such, the easier it will be for someone else to take it and run with it
17:21:39 <whippythellama> think of this like having a makefile for a project, that's all
17:21:49 <whippythellama> ansible is kind of like that
17:22:05 <whippythellama> an enterprise-level makefile :)
17:22:13 <stmiller> heh
17:22:47 <whippythellama> ok, so what are you shooting for next?
17:23:16 <stmiller> So figuring the best way to get it running on 12.04 is currently my todo
17:23:28 <whippythellama> and do we have a good idea of what we need to do before we can swap this in in place of the current site?
17:23:29 <stmiller> I'll experiement more with the input from above
17:23:33 <whippythellama> ok, cool
17:23:43 <whippythellama> try out rbenv in your own account
17:23:59 <whippythellama> ping me if you need help, or check my dotfiles
17:24:09 <stmiller> Yeah just an apache reverse proxy to 127.0.0.1:someport wilil serve up the site.
17:24:18 <whippythellama> i'm running ruby 2.1.2 on my 12.04 box at home via rbenv
17:24:23 <stmiller> ok sweet
17:24:53 <whippythellama> ok, we're running a touch short on time, so we need to move on
17:24:56 <mhrivnak> reverse proxy sounds like there will be a separate web server for jekyl content?
17:25:01 <whippythellama> #topic Systems Status
17:25:19 <whippythellama> qqx: have you had any time to poke about on moya, check current status, etc?
17:25:33 <qqx> No, I've been busy the past week
17:25:51 <whippythellama> ok, cool  :)
17:25:59 <qqx> Should be clearing up a bit though.
17:26:29 <whippythellama> one thing i need to do is update the email aliases
17:26:55 <whippythellama> #action whippythellama update the email aliases
17:27:12 <whippythellama> noticed that b/c we got email about updates that need to be applied on pilot
17:27:24 <whippythellama> and it occurred to me that our sysadmin *might* want to see those  ;)
17:27:28 <mhrivnak> heh
17:27:40 <whippythellama> last thing on this is colo access
17:28:11 <qqx> I'm not sure that *want* is the right word, but it would be useful.
17:28:15 <whippythellama> i believe the only ones who currently have physical access to the colo (near capital & spring forest) are billf and me
17:28:34 <whippythellama> lol - true  :)
17:28:52 <mhrivnak> And are we limited to 2 people with access?
17:28:54 <whippythellama> qqx: i'm not sure where you are physically
17:29:01 <whippythellama> mhrivnak: i don't think so, but i can ask
17:29:05 <qqx> I'm in Durham
17:29:12 <whippythellama> ok, same as jackhill
17:29:31 <whippythellama> the physical access was mostly granted based on location
17:29:46 <whippythellama> i'm about 10 mins from the colo, and i believe bill is close as well
17:29:47 <stmiller> Windstream / Tier Point?
17:30:00 <whippythellama> yep
17:30:09 <whippythellama> departure, i believe
17:30:32 <stmiller> Bandwidth uses them, there is an online portal to add authorized persons
17:30:43 <stmiller> I think that is semi-new
17:31:10 <whippythellama> i believe we have to go thru dash systems for that
17:31:30 <whippythellama> we're not customers of windstream - dash allows us some rackspace in their cage
17:31:48 <whippythellama> ...aaaaand we're at time. drat
17:31:57 <whippythellama> ok, i don't want to keep you all
17:32:01 <whippythellama> #topic General Business
17:32:18 <whippythellama> any hot topics any of you need to cover?
17:32:26 <qqx> no
17:33:10 <stmiller> Nothing here
17:33:18 <mhrivnak> nope
17:33:21 <whippythellama> ok, cool
17:33:35 <whippythellama> thanks, guys!
17:33:37 <whippythellama> #endmeeting