17:03:11 <whippythellama> #startmeeting
17:03:11 <Tribot> Meeting started Tue Jul  5 17:03:11 2016 UTC.  The chair is whippythellama. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:03:11 <Tribot> Useful Commands: #action #agreed #help #info #idea #link #topic.
17:03:19 <whippythellama> #topic Agenda Additions
17:03:31 <mhrivnak> none here
17:03:37 <whippythellama> one thing is the gdi email jackhill brought up
17:03:41 <qqx> nothing here
17:03:56 <stmiller> nothing
17:04:01 <whippythellama> ok, cool
17:04:07 <whippythellama> #topic Fedora Release Party
17:04:12 <whippythellama> mhrivnak: any news there?
17:04:16 <mhrivnak> No news.
17:04:26 <mhrivnak> Everyone was at Summit last week and then there was the long weekend.
17:04:32 <whippythellama> ah, right
17:04:35 <whippythellama> you had mentioned that
17:04:43 <whippythellama> ok, cool
17:04:46 <mhrivnak> I'll email if/when anything happens.
17:04:49 <whippythellama> #topic Moya
17:05:02 <whippythellama> we really let this one slide, i'm afraid
17:05:13 <whippythellama> thank you for emailing about it, stmiller
17:05:47 <stmiller> Yeah I certainly don't want to downplay all efforts to this point, but I think we need something easy to setup and manage
17:05:47 <whippythellama> while i know the general answer is "asap", do you have a feel for when they would like us to pull moya out?
17:05:58 <whippythellama> we do, definitely
17:06:13 <qqx> I have the week off of work, and I'm planning to spend some of that time working on moya.
17:06:21 <mhrivnak> qqx++
17:06:28 <whippythellama> but i also don't want us bogged down trying to get to the "perfect" config for another year
17:06:38 <whippythellama> @qqx++
17:06:55 <stmiller> It has been 1+ year now, assumed the server would be out by now. I was quesitoned on the status based on that
17:07:01 <whippythellama> gotcha
17:07:18 <whippythellama> ok, we need to define a minimum viable product
17:07:31 <whippythellama> ie - where do we need to get in order to pull moya out
17:07:59 <whippythellama> i'm thinking the vm hosting portion, and a pilot-clone vm
17:08:00 <whippythellama> other thoughts?
17:08:01 <stmiller> The current vm on moya is ubuntu 12.04 (vm for pilot replacement)
17:08:06 <mhrivnak> Should we consider just moving pilot as-is to a VM on moya for starters?
17:08:22 <stmiller> So much work. I think starting with clean 16.04 image and moving data over would be best, but that might take more work
17:08:31 <stmiller> 16.04 vm
17:08:37 <whippythellama> how about this...
17:08:56 <whippythellama> keep the 12.04 vm and try to get a straight clone of pilot going on it
17:08:57 <qqx> So far the plan had been to move the current pilot setup over as a VM.
17:09:20 <whippythellama> then spin up a 16.04 vm as 'pilot2' or something and in our copious spare time we try to "do it right"
17:09:29 <mhrivnak> That sounds good. If we can stand up pilot as a VM on moya, we can swap hardware out at the DC, and then iterate from there.
17:09:35 <stmiller> yeah
17:09:35 <whippythellama> exactly
17:10:07 <whippythellama> so is there a base os and then a 12.04 vm running under that?
17:10:33 <stmiller> Yes. Debian, and libvirt / kvm
17:10:40 <whippythellama> excellent
17:11:07 <whippythellama> we do have the backups going on a regular basis
17:11:18 <whippythellama> shall we try a simple restore?
17:11:30 <mhrivnak> ooo nice idea :)
17:11:59 <whippythellama> :)
17:12:04 <whippythellama> kill two birds there
17:12:10 <stmiller> 14.04 still has sysv init, could attempt a restore to 14.04 to see if that would work. Or is that crazy?
17:12:21 <whippythellama> possibly the shortest way to duplicate pilot, and make sure we have restore-able backups
17:12:41 <whippythellama> stmiller: depends on how long the experiment would take
17:13:04 <whippythellama> given how much capacity moya has, i'd rather just go for a straight clone
17:13:04 <qqx> I think attempting to use restore to do an update is a crazy idea in general.
17:13:08 <mhrivnak> Agreed. The quickest path is to keep pilot as-is, and just boot it as a VM on moya.
17:13:20 <qqx> I'd just restore as is, then upgrade that.
17:13:25 <whippythellama> then we could spin up any number of upgraded vms to try to move forward
17:13:28 <whippythellama> qqx: agreed
17:13:42 <qqx> But at this point, I'd keep the upgrade as a separate thing from moving to the VM.
17:13:47 <whippythellama> or restore to a new vm for general use, and then restore to a second vm for upgrade purposes
17:13:53 <stmiller> cool
17:13:53 <whippythellama> exactly
17:14:53 <whippythellama> basically, spin up pilot, warts and all.  once we have a working moya with the new pilot-vm on it, we plan the hw swap
17:15:17 <whippythellama> we will need to figure out a weekend when preferably most of us are around
17:15:48 <whippythellama> and if we can get one or two others who have been involved - jmainguy and aporter come to mind - that would be ideal
17:16:04 <mhrivnak> Sounds good.
17:16:13 <whippythellama> qqx: do you think you can spin up the simple clone this week?
17:16:28 <whippythellama> barring catastrophe, of course :)
17:16:34 <qqx> Hopefully
17:16:39 <stmiller> We might need to audit home dirs
17:17:07 <qqx> Audit for what?
17:17:08 <whippythellama> we may leave that to the users
17:17:24 <stmiller> For space if the disk usage is a lot
17:17:30 <stmiller> ok
17:17:47 <stmiller> I was thinking cloning many GBs might take a bit
17:18:02 <whippythellama> it will - but we'll see how this goes
17:18:07 <stmiller> moya appears to be on a backup TWC link, 15/2 fwif.
17:18:09 <stmiller> w
17:18:47 <mhrivnak> We could do the restore for now without home dirs if necessary.
17:18:50 <whippythellama> worst case, i cart a backup drive to the colo, copy homedirs, then hand it off to you at some point so you can plug it into moya :)
17:18:59 <whippythellama> mhrivnak: i think that's probably best
17:19:00 <mhrivnak> If all the services work, we could wait on home directories until we take moya to the DC.
17:19:11 <whippythellama> agreed
17:19:25 <whippythellama> ok, i think we're good on this one for now
17:19:38 <whippythellama> qqx: can you take the action to get the basic pilot clone up?
17:20:00 <qqx> #action qqx Get pilot clone running on moya
17:20:01 <whippythellama> or restore to the vm, or however you want to phrase it :)
17:20:08 <whippythellama> excellent
17:20:31 <whippythellama> we might actually get that up and running in the next month or so :)
17:20:36 <whippythellama> ok, moving on
17:20:43 <whippythellama> #topic 3d Tuxes
17:20:58 <whippythellama> jeremyhwllc: did you have any news on that?  general status, etc?
17:21:48 <whippythellama> i'm gonna guess he's here in spirit alone :)
17:21:50 <jeremyhwllc> yes
17:21:54 <whippythellama> ah - he lives!  :)
17:21:55 <jeremyhwllc> sorry
17:22:27 <jeremyhwllc> I have had a few emails on it
17:22:41 <whippythellama> yeah, saw some of that
17:23:23 <jeremyhwllc> What are everyone thoughts? swag for sponsorship?
17:23:58 <whippythellama> or for speakers
17:24:48 <mhrivnak> I think I might be a little behing on what exactly the proposal is.
17:25:05 <whippythellama> i'm not certain there really was one
17:25:28 <jeremyhwllc> A guy has a 3d Hubs page
17:25:46 <jeremyhwllc> he wants to self promote on our list
17:26:01 <mhrivnak> Ah right, I recall that part now.
17:26:17 <whippythellama> i also need to point out that we're short on time; there were a couple of other things i wanted to cover
17:26:22 <jeremyhwllc> I recommended instead he make swag in return for sponsorship
17:26:42 <mhrivnak> Gotcha. So now there's a question of whether we want to make speaker swag a regular thing?
17:26:59 <jeremyhwllc> if there is no opposition let move to next topic
17:27:06 <mhrivnak> Seems like it depends at least in part on what it would cost us to make that swag once this guy is done giving us freebies.
17:27:15 <whippythellama> yep
17:27:51 <jeremyhwllc> well there is a 3d hubs community no need to sponsor only one
17:27:52 <whippythellama> ok, sorry jeremyhwllc - we'll need to revisit this one over email or next week
17:28:01 <jeremyhwllc> right
17:28:03 <whippythellama> #topic GDI Email
17:28:36 <whippythellama> so sarah kahn from girl develop it sent in a contact form on 6/29
17:28:57 <whippythellama> basically, they've got a class coming up next wednesday and wanted to know if we could spread the word
17:28:58 <mhrivnak> And does she just want us to email the list and tell them about the event?
17:29:04 <whippythellama> basically, yeah
17:29:43 <whippythellama> it is a paid-for class
17:29:49 <whippythellama> but i don't see any issues
17:29:54 <mhrivnak> Let's do it.
17:29:58 <jeremyhwllc> I vote we promote
17:30:00 <whippythellama> it's a 'command line beginners' class
17:30:01 <whippythellama> coolio
17:30:12 <whippythellama> i'll reach out to her and get her to write something up to send
17:30:12 <qqx> Yeah, I'm for promoting it as well.
17:30:20 <jeremyhwllc> and ask for a future presentation
17:30:27 <whippythellama> #action whippythellama email sarah from gdi about the class
17:30:33 <whippythellama> good idea, jeremyhwllc
17:30:35 <qqx> Even though it's a for pay thing, it's a really low price.
17:30:39 <whippythellama> yeah, it really is
17:30:44 <whippythellama> and they're a good group
17:30:55 <whippythellama> ok, one last thing real quick...
17:31:03 <whippythellama> #topic General Business
17:31:22 <whippythellama> jeremyhwllc: would you mind sending out a final call for presenters for next week's meeting?
17:31:44 <whippythellama> we have three talks scheduled so far
17:31:46 <mhrivnak> Good idea.
17:32:06 <jeremyhwllc> I will kick out the announcements
17:32:07 <whippythellama> pretty good number of rsvps off of meetup
17:32:10 <whippythellama> thank you :)
17:32:11 <mhrivnak> I can lengthen mine if that's helpful.
17:32:15 <jeremyhwllc> after that I need some help
17:32:22 <whippythellama> probably would be, mhrivnak :)
17:32:29 <whippythellama> jeremyhwllc: what can we help with?
17:32:49 <jeremyhwllc> I am getting into the difficult parts of a divorce
17:32:54 <whippythellama> :(
17:33:00 <whippythellama> i'm very sorry to hear that
17:33:02 <jeremyhwllc> wife moving back to Japan
17:33:05 <qqx> Looks like we still need to send to -announce about the meeting.
17:33:25 <mhrivnak> jeremyhwllc, ugh sorry to hear that.
17:33:26 <whippythellama> qqx: noted, thank you - i'll put in the actions, hang on
17:33:57 <whippythellama> #action jeremyhwllc send first round of general meeting announcements
17:34:09 <jeremyhwllc> so next month or two I might not have much time available
17:34:29 <whippythellama> #action jeremyhwllc send a call for more rpi presenters
17:34:32 <stmiller> We've got you covered - no worries
17:34:46 <mhrivnak> jeremyhwllc, ack. Just let us know when you need to hand stuff off and we'll take care of it.
17:34:46 <whippythellama> jeremyhwllc: we'll take care of anything you need
17:35:10 <jeremyhwllc> thanks
17:35:11 <jackhill> does it have to be rpi, or would any embedded/single-board-computer count? (not that I really have any leads, just curious)
17:35:30 <whippythellama> and if there are any in-flight conversations you'd like us to take over, just cc and let us know
17:36:10 <jeremyhwllc> I think we can add as rpi alternatives
17:36:13 <whippythellama> jackhill: very strongly prefer rpi i'd say, just because that's what we've listed on the site, but i very much doubt anyone would object too strongly  ;)
17:36:32 <jackhill> cool
17:36:37 <whippythellama> ok, we're well over time here - anyone have additional topics?
17:36:45 <mhrivnak> None here.
17:36:57 <jeremyhwllc> none
17:36:59 <qqx> nope
17:37:06 <stmiller> I'll ask around for rpi presenters.
17:37:07 <whippythellama> ok, cool
17:37:14 <whippythellama> thank you, stmiller!  :)
17:37:29 <whippythellama> and on that note - thank you everyone!
17:37:31 <whippythellama> #endmeeting