18:32:24 <whippythellama> #startmeeting
18:32:24 <Tribot> Meeting started Mon Nov 21 18:32:24 2016 UTC.  The chair is whippythellama. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:32:24 <Tribot> Useful Commands: #action #agreed #help #info #idea #link #topic.
18:32:32 <whippythellama> #chair mhrivnak stmiller qqx whippythellama
18:32:32 <Tribot> Current chairs: mhrivnak qqx stmiller whippythellama
18:32:42 <whippythellama> #topic Check for Agenda Additions
18:32:49 <whippythellama> anyone have anything they need to add?
18:32:55 <qqx> nope
18:32:57 <mhrivnak> nope
18:33:10 <stmiller> nope
18:33:16 <whippythellama> the nopes have it :)
18:33:21 <whippythellama> #topic Moya Recap
18:33:34 <mhrivnak> woot!
18:33:36 <whippythellama> tribot is coming to us live from our shiny new server - woo hoo!
18:33:53 <qqx> Still a couple of outstanding issues.
18:34:14 <whippythellama> i played dumb at windstream when they talked about removing equipment - since it was a swap, there wasn't really any trouble about it
18:34:18 <qqx> Main one being a problem with outbound IPv6.
18:34:31 <whippythellama> i need to upload the couple of pics i took :)
18:34:43 <whippythellama> qqx: this related to the backup email you replied to earlier?
18:34:51 <qqx> Pilot keeps adding an address on the HE tunnel block and using that as the default, even though it's not reachable.
18:34:53 <whippythellama> and may i just say
18:34:59 <whippythellama> @qqx++
18:35:07 <whippythellama> dude, you are THE MAN
18:35:09 <qqx> whippythellama: Yes, it's the root cause of the backup failures.
18:35:37 <whippythellama> any hiccups since the swap have been pretty minor from the user perspective, if any at all
18:35:41 <whippythellama> you rocked that!
18:35:41 <qqx> I *think* taking eth0 down and bringing it back up may fix things.
18:35:47 <whippythellama> hehe
18:35:55 <whippythellama> ok, let me know when i should head to the colo  ;)
18:36:01 <mhrivnak> heh
18:36:17 <qqx> Shouldn't need any colo access. Can get console access from moya.
18:36:26 <whippythellama> ok, cool
18:36:33 <whippythellama> i need to check my access at that level
18:36:46 <whippythellama> i wasn't able to log in from a physical console on saturday
18:36:57 <stmiller> The ipv6 appears to be using dhcp for he.net, but could just set a static for v6
18:37:23 <qqx> I've been temporarily fixing the problem with `ip a delete 2001:470:7:11ec::2 dev eth0`
18:37:58 <whippythellama> the front panel errors still concern me
18:38:07 <qqx> Yeah, could use static IP info, although I was trying to keep the network config mostly consolidated.
18:38:19 <whippythellama> qqx: have you seen any disk errors in moya's logs?
18:38:53 <qqx> The other outstanding issue is that for now haproxy isn't working in transparent mode, so all IPv4 access will show as coming from moya's internal address.
18:39:49 <whippythellama> yeah, that's a bummer
18:39:57 <whippythellama> i can't ssh into moya, btw
18:40:00 <qqx> I haven't seen disk errors, but I hadn't really looked for them.
18:40:06 <whippythellama> yeah, i figured
18:40:11 <whippythellama> more pressing issues
18:40:22 <whippythellama> it's something i'd like to check
18:40:27 <mhrivnak> agreed.
18:40:30 <whippythellama> and i'd be happy to, but i can't seem to ssh into moya :)
18:40:41 <mhrivnak> We'll sleep easier knowing the disks are ok. :)
18:40:55 <qqx> whippythellama: What user are you trying to login as?
18:40:55 <whippythellama> especially since they're brand-friggin-new!
18:40:58 <stmiller> he.net tunnel requires a static for v6 (at least for the host receiving your endpoint)
18:41:02 <whippythellama> qqx: bgerard
18:41:14 <whippythellama> my login on pilot
18:41:46 <qqx> The only accounts on moya currently are root and aschrab.
18:42:11 <whippythellama> well that would explain that :)
18:42:19 <whippythellama> could you enable the rest of the sc?
18:43:11 <qqx> I can, although I'll need to figure out what to do about initial passwords.
18:43:27 <qqx> That will need to wait until after work.
18:43:39 <whippythellama> oh sure, i didn't mean "while we wait"  :)
18:43:41 <qqx> @action qqx Add accounts on moya for SC members.
18:43:46 <whippythellama> thank you, sir :)
18:44:29 <whippythellama> we can figure out the temporary/initial password thing
18:44:41 <whippythellama> ok, anything else on moya for the moment?
18:45:02 <qqx> Nothing urgent.
18:45:17 <whippythellama> anything you'd like help with?
18:45:19 <qqx> Although now that that's done it would be nice to check into native IPv6.
18:45:26 <whippythellama> that it would
18:45:53 <stmiller> I can help with ipv6 if you want
18:45:59 <qqx> Also it appears that we need to get non-StartSSL certs for www and steering, Firefox doesn't like those.
18:46:00 <stmiller> he.net v6, that is
18:46:11 <whippythellama> we will, yes, qqx
18:46:24 <qqx> stmiller: Trying to get non-HE v6.
18:46:40 <whippythellama> the current ones *should* be fine until they expire, but we can't get any new ones from startssl because of that
18:47:03 <whippythellama> we had discussed using letsencrypt, i believe
18:47:13 <qqx> No, even now Firefox is saying that the certs aren't trusted.
18:47:21 <whippythellama> lovely  :/
18:47:30 <whippythellama> that wasn't supposed to be the case
18:47:40 <qqx> I did a bit of an attempt at getting letsencrypt working yesterday.
18:48:15 <whippythellama> i think coxn (and stmiller?) had offered to help setting letsencrypt up, iirc
18:48:28 <qqx> Got it running, but it's failing to authenticate. I think because of how apache is configured to redirect almost everything.
18:48:35 <whippythellama> hrm...
18:49:17 <whippythellama> ok, we can discuss this further on the list or next week; i'd like to move on so we can get to the holiday party
18:49:22 <mhrivnak> +1
18:49:26 <whippythellama> #topic November Hack Night Recap
18:49:29 <stmiller> I can help get letsencrypt working yeah. (onward)
18:49:36 <qqx> apache also isn't allowing access to the email autoconfig URL used by (at least) Thunderbird. Which is under the same top level directory as used by letsencrypt.
18:49:37 <whippythellama> thank you, stmiller :)
18:49:57 <whippythellama> stmiller's presentation was well received, i thought
18:50:04 <whippythellama> i certainly liked it  :)
18:50:16 <whippythellama> and thank you for your show-n-tell, stmiller
18:50:26 <qqx> Much better turn out than the last couple of hack nights. :)
18:50:27 <stmiller> Ha thanks I wasn't sure if anyone would be there. Had a few
18:50:45 <whippythellama> qqx: that's sure the case!
18:51:18 <whippythellama> i think the lesson to take away there is that having a topic or theme helps
18:51:44 <mhrivnak> agreed.
18:51:44 <whippythellama> the last few before that were generic "come do whatever" kinds of hack nights
18:52:19 <whippythellama> i think most folks were probably thinking why do that when i can do the same thing at home with my 27" monitor?
18:52:25 <whippythellama> :)
18:52:34 <whippythellama> any other thoughts on hack night?
18:52:46 <stmiller> Just takes effort and time of someone(s) to run hack nights. I'm currently at a max though with kid activities or other things.
18:52:58 <whippythellama> stmiller: agreed
18:53:12 <stmiller> For now we need a steering person or other person to take each on, or just skip them.
18:53:13 <whippythellama> but qqx was running it just fine for a couple of months there
18:53:44 <whippythellama> agreed again
18:53:52 <whippythellama> ok, let's move on to the holiday party
18:53:57 <whippythellama> #topic Holiday Party
18:54:10 <whippythellama> mhrivnak: thank you VERY much for securing the annex for us!
18:54:15 <mhrivnak> Sure thing.
18:54:26 <whippythellama> what times do we have?
18:54:38 <mhrivnak> It's on the calendar 6:30-9:30.
18:54:45 <whippythellama> i will call neomonde and see about the food
18:54:51 <mhrivnak> And I said we'd advertise 7-9
18:54:56 <whippythellama> mhrivnak: ok, cool
18:54:59 <whippythellama> heh... good call :)
18:55:26 <whippythellama> we need to make initial announcements and get the rsvp form up online
18:55:41 <whippythellama> and update the site and meetup
18:55:41 <mhrivnak> We can potentially use meetup as the RSVP collector.
18:56:04 <whippythellama> i'm open to that, providing it gives us the details we need
18:56:07 <mhrivnak> It also has the option to let us ask attendees specific questions. I'm not sure if that'll meet our needs, but we should look at it.
18:56:16 <whippythellama> mhrivnak: thank you!
18:56:25 <mhrivnak> Having 2 places to RSVP could be confusing.
18:56:30 <qqx> Probably best to try to use meetup.
18:56:41 <qqx> mhrivnak: That was my thinking as well.
18:56:43 <mhrivnak> What questions do we need to ask?
18:56:51 <whippythellama> how many coming with you
18:56:54 <mhrivnak> I suppose we can dig out last year's form.
19:01:01 <whippythellama> ...well there goes our scribe
19:01:14 <qqx> I don't think it will ask for that information after someone has RSVPd.
19:01:23 <whippythellama> qqx: good point
19:01:37 <whippythellama> stmiller: excellent - that should help
19:01:49 <whippythellama> ok, i'll take this to email
19:02:02 <whippythellama> we're over, and i'm  not sure if tribot still knows he's taking notes
19:02:08 <qqx> Can polls be tied to an event?
19:02:19 <stmiller> Not sure
19:02:19 <whippythellama> #action whippythellama email sc regarding holiday party tasks
19:02:49 <whippythellama> mhrivnak is checking into meetup's rsvp/form capabilities
19:03:17 <qqx> Did somebody else remove the extra IPv6 address from pilot?
19:03:23 <whippythellama> not i
19:03:36 <stmiller> That was me, looks like I made tribot mad
19:03:41 <whippythellama> aah
19:03:44 <whippythellama> heh, oops
19:03:44 <mhrivnak> heh
19:04:12 <qqx> That's a shame, I'd been hoping that the problem had resolved itself.
19:04:14 <whippythellama> ok, we're almost 5 mins over; i don't want to keep everyone
19:04:34 <whippythellama> thanks everybody!
19:04:36 <whippythellama> #endmeeting