16:02:21 <whippythellama> #startmeeting
16:02:22 <Tribot> Meeting started Wed Jan  4 16:02:21 2017 UTC.  The chair is whippythellama. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:02:22 <Tribot> Useful Commands: #action #agreed #help #info #idea #link #topic.
16:02:30 <whippythellama> #chair stmiller qqx mhrivnak whippythellama
16:02:30 <Tribot> Current chairs: mhrivnak qqx stmiller whippythellama
16:02:51 <whippythellama> #topic Check for Agenda Additions
16:03:18 <qqx> Nothing here
16:03:36 <whippythellama> stmiller: i believe you wanted to discuss migrating off of ubuntu 12.04
16:03:53 <whippythellama> mhrivnak: you mentioned the wireless mic purchase just before the meeting
16:04:33 <whippythellama> other than those, do either of you have anything else
16:04:50 <stmiller> That sounds good, nothing else for me
16:05:08 <whippythellama> ok, cool
16:05:15 <whippythellama> #topic January Meeting
16:05:39 <whippythellama> Jeff replied to my email, so hopefully we'll have something from him today
16:05:45 <stmiller> Oh? Ok great
16:06:04 <stmiller> ah yeah sweet
16:06:09 <whippythellama> i'll put something in place on the sites regardless, but i'm hoping it will be the real thing
16:06:28 <stmiller> RHEV was recently renamed to just RHV
16:06:30 <whippythellama> #action whippythellama update trilug.org and meetup with meeting info
16:06:37 <mhrivnak> Ya, we should probably have put a placeholder on meetup a while ago.
16:06:48 <whippythellama> agreed
16:07:01 <whippythellama> i blame 2016
16:07:15 <mhrivnak> Easy target. :)
16:07:26 <whippythellama> isn't it?  :)
16:07:35 <whippythellama> i'm planning on being there - how about the rest of you?
16:07:39 <qqx> Especially with it not being around any more to defend itself.
16:07:42 <mhrivnak> If we have Frontier confirmed for Feb and March, we should put placeholders on meetup for those too.
16:07:43 <whippythellama> qqx: exactly
16:07:46 <mhrivnak> I will be there.
16:07:48 <qqx> I plan to be there.
16:08:06 <stmiller> I'll be there
16:08:07 <whippythellama> mhrivnak: good point, and we need to confirm that we actually *do* have it confirmed
16:08:26 <whippythellama> #action whippythellama find out our frontier reservation status
16:09:06 <whippythellama> who wants to send out the first announcements once the sites have been updated?
16:09:26 <stmiller> I can give that a shot
16:09:35 <whippythellama> awesome - thank you, stmiller
16:09:39 <mhrivnak> That sounds good. stmiller you can give a little personal endorsement too.
16:09:46 <whippythellama> good idea
16:10:19 <whippythellama> stmiller: can you action that?
16:10:34 <whippythellama> anything else about the january meeting?
16:10:36 <stmiller> #action stmiller send announcement blasts for Jan meeting
16:10:45 <whippythellama> thanks  :)
16:11:20 <mhrivnak> nothing here
16:11:25 <stmiller> nothing
16:11:30 <qqx> nope
16:11:35 <whippythellama> coolio.. moving on
16:11:40 <whippythellama> #topic Future Topics
16:11:41 <jeremyhwllc> here!
16:11:53 <whippythellama> hey there, jeremyhwllc - welcome back!  :)
16:12:23 <whippythellama> we just covered the january meeting - anything you needed to add to the agenda, or address for january?
16:12:59 <jeremyhwllc> i am still covered up. not sure I can be of much assistance for Jan
16:13:10 <whippythellama> no worries, just wanted to check
16:13:12 <mhrivnak> I just checked with the selinux person. He can't do Feb but would like to do March.
16:13:20 <whippythellama> mhrivnak: that's great!
16:13:35 <jeremyhwllc> awesome!
16:13:36 <whippythellama> i pinged Sean Alexandre - turns out he's moved out of the area
16:13:48 <whippythellama> so no linux server security talk  :(
16:13:54 <mhrivnak> :(
16:13:57 <whippythellama> i still need to ping the drone folks
16:14:23 <whippythellama> #action whippythellama reach out to the drone speakers and see if/when they can come
16:14:45 <mhrivnak> I'll claim march for selinux on the wiki.
16:14:59 <mhrivnak> Are drones our best bet for next month?
16:15:09 <whippythellama> february will be a tight timeline unless they have something prepared :/
16:15:25 <mhrivnak> wow, our poor neglected wiki: https://steering.trilug.org/wiki/index.php/UpcomingMeetings
16:15:35 <whippythellama> we may have to pull the lightning talk card
16:15:52 <whippythellama> yeah, the sc wiki definitely needs some love
16:16:59 <whippythellama> when was the last time we had lightning talks?
16:17:18 <mhrivnak> Feb 2016 it looks like. :)
16:17:19 <whippythellama> obviously i can go back and check the site, but do any of you remember offhand?
16:17:24 <whippythellama> lol
16:17:28 <whippythellama> i sense a pattern
16:17:30 <mhrivnak> heh, ya.
16:18:36 <whippythellama> ok, i'll see if we can get the drone talk for february; otherwise, unless someone has something ready to go we may need to do that again
16:18:54 <whippythellama> any of you have any other leads?
16:18:58 <mhrivnak> Sounds good. We can re-visit on Monday.
16:19:07 <whippythellama> that works
16:19:10 <jeremyhwllc> I just pinged Adrian the drone speaker
16:19:18 <stmiller> I have a co-worker who could talk about some fancy AWS stuff, not sure how a lug audience would like it or not
16:19:19 <stmiller> https://jinwright.net/how-deploy-serverless-wsgi-app-using-zappa/
16:19:21 <whippythellama> jeremyhwllc: oh, excellent - thank you!
16:19:22 <mhrivnak> I'll do some thinking and see if anything around here would be viable.
16:19:41 <whippythellama> stmiller: that might go over well
16:19:59 <stmiller> Running a django website, serverless in AWS
16:20:07 <whippythellama> nifty!
16:20:32 <mhrivnak> Nice.
16:20:39 <whippythellama> so yeah, that's a possibility
16:20:56 <whippythellama> and we'll see what Adrian says
16:21:19 <whippythellama> #topic Tech Items
16:21:55 <whippythellama> qqx: you had mentioned the potential for a reboot at some point, to see if the haproxy config sticks
16:22:08 <whippythellama> is haproxy still behaving itself?
16:22:39 <qqx> The website is still accessible via IPv4, so yes. :)
16:22:56 <whippythellama> hehe  :)
16:23:06 <qqx> Not too concerned about it breaking without a reboot.
16:23:20 <whippythellama> any thoughts on when you'd want to bounce it?
16:23:37 <qqx> And I don't think it deserves a separate reboot for testing that.
16:24:11 <whippythellama> fair enough - so just whenever the next time is that it needs a reboot anyway, then
16:24:15 <qqx> Although I believe there is a pending kernel update for pilot, so it would probably make sense to reboot moya for that.
16:24:42 <whippythellama> yep, that would work
16:24:43 <qqx> Since there's not really anything else that matters on moya at the moment.
16:25:09 <whippythellama> let me know when you want to do that and we can make sure i'll be in town for it
16:25:22 <qqx> Would this Sat morning work for you?
16:25:45 <whippythellama> yeah, i believe it would... assuming we're not in for another snowmageddon
16:26:16 <qqx> Ahh, good point. Might be better to wait a bit due to the weather.
16:26:38 <whippythellama> yeah
16:26:52 <whippythellama> if i'm here and the roads are clear, the reboot will go off without a hitch
16:27:21 <whippythellama> if there's ice, or i pop down to myrtle or something, that's when moya takes a dirt nap
16:27:33 <qqx> Of course.
16:28:07 <whippythellama> on the phpmailer issue, as i mentioned in email i moved the survey site directory out of the way, so we're at least not trivially vulnerable now
16:28:29 <whippythellama> but we should look at whether or not we really need to keep that software around
16:28:51 <mhrivnak> I think it's unlikely. We should probably garbage-collect it.
16:28:56 <qqx> I doubt if we do need to keep that.
16:29:11 <whippythellama> i agree
16:29:27 <whippythellama> jeremyhwllc, stmiller - you guys have any thoughts on it?
16:29:27 <qqx> Probably get garbage collected as part of moving off of the old Ubuntu.
16:29:37 <whippythellama> qqx: likely so
16:29:50 <mhrivnak> Good point.
16:29:55 <stmiller> It appeared unused since 2011 or so
16:30:20 <whippythellama> so it will most likely not be missed
16:30:50 <whippythellama> speaking of the migration, anyone have thoughts on what we want to migrate to?
16:30:58 <qqx> I need to go now.
16:31:01 <whippythellama> easiest would be ubuntu 14.04
16:31:07 <whippythellama> qqx: gotcha, thank you!
16:31:10 <mhrivnak> heh.
16:31:20 <qqx> For the mic talk, I vote yes on the purchase.
16:31:21 <whippythellama> yeah, we're just past time
16:31:25 <stmiller> ubuntu 14.04 would make the most sense as it is still apache2.2
16:31:29 <mhrivnak> whippythellama asks the distro question, qqx runs for the hills
16:31:39 <whippythellama> lol.. yeah, i noticed that  ;)
16:31:39 <stmiller> Otherwise would need to alter all the apache stuff for 2.4 in 16.04
16:31:47 <whippythellama> stmiller: excellent point
16:32:11 <whippythellama> it would at least buy us some time
16:32:21 <stmiller> Since we are short on time yeah
16:32:21 <whippythellama> with a (hopefully) minimal impact
16:32:22 <mhrivnak> I think we want to setup a new web host and migrate sites to it, right?
16:32:40 <mhrivnak> same for email, DNS and other services?
16:32:52 <whippythellama> i believe so, yeah
16:32:53 <mhrivnak> not sure we need a separate host for each.
16:32:58 <stmiller> I think so yes, if there is any way to setup a new VM on there
16:33:13 <whippythellama> yeah, the original thought was to have moya host a bunch of vms
16:33:18 <mhrivnak> But I think the idea is: move services off of pilot onto one or more new VMs.
16:33:32 <mhrivnak> Then we can upgrade pilot itself to whatever.
16:33:36 <whippythellama> i'm good with that approach
16:33:46 <mhrivnak> and pilot becomes primarily a shell server for members.
16:33:56 <whippythellama> have one vm for services/admin, and then the login host
16:34:05 <whippythellama> what you're saying, yeah  :)
16:34:21 <whippythellama> might make the upgrade easier too
16:34:40 <mhrivnak> So given that, I think we'd go for the newest LTS of whatever distro we want and start migrating services to it.
16:34:41 <whippythellama> spin up a fresh 14.04 vm on moya and start pulling a service at a time over from pilot
16:34:51 <mhrivnak> why not go 16.04?
16:35:11 <whippythellama> depends on how quickly we can do it
16:35:12 <stmiller> In that case yeah 16.04
16:36:34 <whippythellama> i've been having performance issues with 16.04, but that is on a laptop
16:37:07 <whippythellama> ok, we're over time here - i don't want to keep everyone overlong
16:37:10 <whippythellama> so real quick...
16:37:14 <whippythellama> #topic General Business
16:37:31 <whippythellama> stmiller: you still planning on doing the libregaming hack night?
16:37:44 <whippythellama> and qqx has already voted 'aye' for the wireless mic
16:37:48 <whippythellama> i would also vote yes
16:38:19 <whippythellama> stmiller, jeremyhwllc - your votes on the wireless mic?
16:38:27 <whippythellama> ...assuming anyone is still around...
16:38:42 <stmiller> oops back
16:38:58 <mhrivnak> We approved it previously. I just wanted to re-confirm.
16:39:00 <whippythellama> heh... no problem; like i said, i know we're over time
16:39:05 <stmiller> yes re: libregaming. I'll get a list of potential games to get steering@ thoughts / feedback
16:39:07 <jeremyhwllc> i vote in favor
16:39:14 <whippythellama> stmiller: excellent
16:39:18 <whippythellama> thank you!
16:39:22 <whippythellama> thank you, jeremyhwllc
16:39:52 <whippythellama> stmiller: any reservations about the mic?
16:40:01 <stmiller> oh in favor. +1
16:40:05 <whippythellama> awesome
16:40:11 <whippythellama> that's unanimous, then
16:40:11 <mhrivnak> Sweet. I'll make it so.
16:40:21 <whippythellama> excellent - thank you, mhrivnak!
16:40:55 <whippythellama> ok, since we're SO far over, i'm going to say if there's anything else we should take it to email
16:41:00 <whippythellama> thank you all for coming!
16:41:07 <whippythellama> #endmeeting