17:31:44 <whippythellama> #startmeeting
17:31:44 <Tribot> Meeting started Mon Apr  3 17:31:44 2017 UTC.  The chair is whippythellama. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:31:44 <Tribot> Useful Commands: #action #agreed #help #info #idea #link #topic.
17:31:54 <whippythellama> #chair qqx stmiller whippythellama
17:31:54 <Tribot> Current chairs: qqx stmiller whippythellama
17:32:06 <whippythellama> #topic Check for Agenda Additions
17:32:16 <whippythellama> anything either of you would like to add?
17:32:36 <qqx> Yes
17:32:52 <whippythellama> cool - what's that?
17:33:04 <qqx> We should probably have method of getting updated contact info for members.
17:33:38 <whippythellama> ok, sounds good - let's discuss that in general business
17:33:57 <whippythellama> we'll make the rest of the agenda quick
17:34:01 <whippythellama> stmiller: anything from you?
17:34:26 <stmiller> nothing
17:34:37 <whippythellama> ok, cool
17:34:40 <whippythellama> #topic April Meeting
17:34:46 <whippythellama> i'll be there
17:34:59 <whippythellama> how about you guys?
17:35:01 <stmiller> Same, I'm coming
17:35:09 <whippythellama> excellent!
17:35:26 <whippythellama> i'll ping jeremyhwllc about sending the first round of announcements
17:35:28 <qqx> I'll be there as well.
17:35:38 <whippythellama> #action whippythellama ping jeremyhwllc regarding announcements
17:35:47 <whippythellama> great, qqx!
17:36:03 <whippythellama> ok, anything else about this month's meeting for now?
17:36:10 <qqx> no
17:36:25 <stmiller> I'll ping Brian to make sure he's all set
17:36:30 <stmiller> The presenter Brian
17:36:33 <whippythellama> that took me a second  :)
17:36:43 <whippythellama> ok, thank you stmiller :)
17:36:52 <whippythellama> #topic Future Topics
17:37:02 <stmiller> #action stmiller give bjinwright a ping
17:37:14 <whippythellama> i pinged our contact form person - i'm hoping we can get him for may
17:37:27 <whippythellama> mhrivnak has indicated that june will work for him
17:37:59 <whippythellama> and this month's speaker was interested in doing a follow-up in july, i believe
17:38:08 <whippythellama> so that's a pretty good runway :)
17:38:33 <whippythellama> have either of you run across any other presentations or speakers you think would be a good fit?
17:38:58 <qqx> Not I.
17:39:05 <stmiller> Haven't yet, I'm still constantly asking around though
17:39:11 <whippythellama> thank you, stmiller
17:39:28 <whippythellama> ok, well like i said, we have some wiggle room yet  :)
17:39:42 <whippythellama> feel free to point any prospects my way
17:39:51 <stmiller> ok
17:40:08 <whippythellama> movin along...
17:40:20 <whippythellama> #topic Elections / Nominations
17:40:33 <whippythellama> stmiller: have you tapped anyone as a prospective replacement yet?
17:41:16 <whippythellama> qqx: if you're still planning on re-running (please! :), nominations are open - go ahead and self-nominate
17:41:23 <whippythellama> ..speaking of which...
17:41:23 <stmiller> negative. I wonder if mmarley would consider
17:41:29 <whippythellama> #action whippythellama self-nominate
17:41:38 <whippythellama> stmiller: could be - wanna ping him?
17:41:39 <qqx> #action qqx self-nominate
17:42:19 <whippythellama> may as well make it a clean sweep...
17:42:25 <whippythellama> #action mhrivnak self-nominate
17:42:32 <whippythellama> #action jeremyhwllc self-nominate
17:42:34 <whippythellama> there :)
17:42:39 <whippythellama> i think that's it on elections for now
17:42:44 <whippythellama> #topic Sponsorships
17:43:04 <whippythellama> i have one potential on the hook, not sure for which month tho
17:43:21 <whippythellama> if you guys have any leads in that arena, please pass em my way
17:44:04 <whippythellama> that includes if you're chatting with a recruiter - if you want to send me their contact info, i'll follow up with them
17:44:16 <stmiller> ok yeah
17:44:42 <whippythellama> ok, onward...
17:44:47 <whippythellama> #topic Tech Items
17:45:00 <whippythellama> anything on the pilot os upgrade, qqx?
17:45:08 <qqx> No :(
17:45:15 <whippythellama> and stmiller - any more work on the drupal replacement?
17:45:28 <whippythellama> no problem - i can totally relate
17:45:47 <whippythellama> $work is eating all kinds of my time lately
17:46:03 <stmiller> I've glanced at it, I think it is doable but probably after May
17:46:09 <stmiller> spring time is crazy for some reason
17:46:16 <whippythellama> yeah, gotcha
17:46:23 <whippythellama> let me ask this
17:46:52 <whippythellama> are you planning on continuing to work on that after you've left the sc, or hand it off to the next sc?
17:47:09 <whippythellama> it's fine either way, i just want to have an idea
17:47:45 <stmiller> oh, yeah will continue even post-sc
17:47:54 <whippythellama> ok, that's awesome - thank you!  :)
17:48:17 <whippythellama> alright, movin right along...
17:48:25 <whippythellama> #topic General Business
17:48:39 <whippythellama> qqx: you wanted to talk about updating members' contact info
17:48:46 <whippythellama> what's the context?
17:48:58 <whippythellama> i mean, i'm not opposed to it - i'm just wondering how it came up
17:49:14 <qqx> Most recent was a bunch of spam being sent through pilot using a member account.
17:49:38 <qqx> The alternate email address in the membership DB is out of date, and there's no other contact info.
17:49:42 <stmiller> Might be also useful to reach out to someone storing tons of data
17:50:01 <whippythellama> yeah, both good points
17:50:01 <stmiller> as another scenario
17:50:14 <stmiller> I think we have a few of those storing gigs
17:50:22 <qqx> Fortunately in this case the name was fairly unique and I was able to find a different email address in the mailman subscriber list.
17:50:25 <stmiller> And not sure if they are active anymore
17:51:02 <qqx> From what I recall the users using the most disk space are pretty clearly active.
17:51:10 <whippythellama> so there's not currently a self-service type solution we have for folks to update their own info
17:51:18 <whippythellama> that i'm aware of, at least
17:51:34 <whippythellama> we can do it via the membership db interface, but it's one-at-a-time
17:51:58 <qqx> Right. Having a way for them to do that would be a pretty much necessary pre-condition.
17:52:07 <whippythellama> yeah, that's my thought
17:52:28 <whippythellama> i have zero interest in going through 800+ members and updating addresses
17:52:48 <qqx> For people that we have a current email address it would be pretty easy to ask them to verify that their info is up to date.
17:53:11 <whippythellama> very true
17:53:16 <qqx> But there isn't really a good way to handle cases where that is already outdated.
17:53:39 <whippythellama> yeah, and the other thing is finding a way to do it so it's authenticated
17:53:54 <whippythellama> very few have logins on the web site, and not everyone has a shell
17:54:09 <whippythellama> so we need to put some thought into that
17:54:18 <whippythellama> ideas?
17:54:29 <stmiller> And make sure communication doesn't look like a phishing scam
17:54:35 <qqx> I think having a unique link per account with a hash, which we email to them.
17:54:53 <whippythellama> lol... good point, stmiller - that is definitely a concern :)
17:54:53 <qqx> Yeah, avoiding looking like phishing would be a definite issue.
17:55:14 <whippythellama> hadn't gotten that far yet  :)
17:55:56 <whippythellama> hmm.... we could have them email us, and then we send back the link with their info if we find their email in the db
17:56:36 <qqx> I'd like to avoid the need for us to be a part of it.
17:56:52 <whippythellama> oh no - i meant automated
17:57:03 <whippythellama> set up a 'validate.me@trilug.org' address
17:57:28 <whippythellama> have it kick something off when it receives an email that checks if the sender is in the db
17:57:39 <whippythellama> if it is, generate that hashed url you mentioned and send it back
17:58:04 <whippythellama> because i'm completely on board with having as little manual intervention as possible
17:58:21 <qqx> Having it initiated via email seems to be more difficult than doing that with a web page, and doesn't seem to have any advantages.
17:58:58 <whippythellama> how would a web page version work?
17:59:33 <qqx> Pretty much the same, they go to a web page, enter their email address and we send a unique link to that address.
17:59:38 <whippythellama> ...we're coming up on time, btw; i can stick around a few minutes, but i just wanted to mention it in case either of you have a hard stop
18:00:15 <qqx> We should probably also have a way for people to get the link from a shell account, for people who still have access to that but have an old email in the DB.
18:00:16 <whippythellama> sure, that would work - and if they're not in the db, no mail is sent
18:00:19 <stmiller> Also since its voluntary to update one's info have to account for many users perhaps just ignoring
18:00:23 <whippythellama> qqx: agreed
18:00:40 <whippythellama> stmiller: also true
18:01:03 <stmiller> Might have to set some motivators if we can think of any. Old accounts: getting blah. Update your info, and unlock something. Or I don't yeah
18:01:08 <qqx> Even if they aren't actively ignoring, I'm sure there will be plenty of people who we can't contact due to out dated info.
18:01:27 <whippythellama> very true - we may have no choice but to do manual updates in those cases
18:01:34 <whippythellama> but i'm hoping they're somewhat rare
18:01:47 <whippythellama> between a web form and a shell solution, i mean
18:01:55 <qqx> I'm mostly concerned about it for people with shell accounts.
18:02:07 <whippythellama> as far as incentives go, it may be more of a stick than a carrot
18:02:16 <qqx> One benefit for them is having a way to get the password reset when needed.
18:02:26 <whippythellama> basically, our use cases are 'if we have any problems with your account, we need a way to get in touch with you'
18:02:46 <whippythellama> so if we don't have a way to reach them, it's a locked account, that sort of thing
18:02:52 <whippythellama> qqx: that too
18:04:23 <whippythellama> ok, so we can come up with a basic sketch of what this will look like and see what the rest of the sc thinks - it seems like we have a decent start
18:04:36 <qqx> But, it probably pays to wait on trying to implement the member UI for updating info until after the OS upgrade.
18:04:52 <whippythellama> "sketch" being a description more than any kind of proof of concept
18:04:58 <whippythellama> qqx: that's fine
18:05:36 <whippythellama> this is something that's been missing for a long while - i don't think waiting a couple more months is going to kill us :)
18:05:48 <qqx> Yep
18:05:52 <whippythellama> ok, we're five minutes over - any other last minute items?
18:05:59 <whippythellama> ...and thank you for bringing that up, qqx
18:06:00 <qqx> Nothing here.
18:06:08 <stmiller> Go heels?
18:06:11 <whippythellama> lol
18:06:40 <stmiller> nothing else for me
18:06:43 <whippythellama> tar: heels not found
18:06:45 <whippythellama> :)
18:07:00 <whippythellama> ok, thanks guys!
18:07:04 <whippythellama> #endmeeting