17:29:19 <Jmainguy> #startmeeting
17:29:19 <Tribot> Meeting started Mon Sep 21 17:29:19 2020 UTC.  The chair is Jmainguy. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:29:19 <Tribot> Useful Commands: #action #agreed #help #info #idea #link #topic.
17:29:27 <Jmainguy> hows everyone doing today?
17:29:37 <noway2> Good for a Moanday.
17:29:47 <Jmainguy> =) I hear yah there
17:31:43 <Jmainguy> #chair noway2
17:31:43 <Tribot> Current chairs: Jmainguy noway2
17:33:05 <Jmainguy> #chair jeoff
17:33:05 <Tribot> Current chairs: Jmainguy jeoff noway2
17:34:32 <Jmainguy> #topic Review action items from last meeting
17:34:53 <Jmainguy> I did not do my action items, cuz im a jerk
17:34:59 <Jmainguy> I will try and do them this week
17:35:09 <Jmainguy> #action Jmainguy will perform his action items from last meeting
17:35:19 <Jmainguy> bdmc: you around or nah?
17:35:46 <Jmainguy> #topic agenda additions
17:35:52 <Jmainguy> yall have anything to add to the agenda today?
17:36:02 <noway2> I did some work on auditing pilot, we could discuss.
17:36:12 <Jmainguy> I am all for that
17:36:14 <Jmainguy> jeoff: anything?
17:36:26 <Jmainguy> or should we dive right into the pilot?
17:36:44 <jeoff> Jmainguy: I would like to add meeting boilerplate stuff in the future, but there is nothing currently
17:37:05 <Jmainguy> jeoff: ack
17:37:11 <Jmainguy> #topic pilot audit
17:37:14 <Jmainguy> noway2: take it away
17:37:28 <noway2> Ok, let me type some stuff out ... please stand by
17:37:39 <Jmainguy> ack
17:40:28 <noway2> Pilot is currently running Ubuntu 12. It i=has a 240Gb disk, of which / is 83% full and /home is 73% full running an early LVM on /dev/mapper. It is a 4G ram machine with 2 dual core processors assigned. I think disk is our critical resource. A lot of home folders have python and rails VMs in them which is probably where a lot of the usage is. I captured the running process and installed applications. I have these in files that I could share (option?)
17:40:29 <noway2> .   It is running SysV with Upstard - pre SystemD. I did poke around in some of the cofig files for Apache, Postfix, etc. I think it can largely be duplicated but the best way to update it would be to spin up a new image. Whether we want to re-install some of the old packages, like outdated Ruby, etc is in question.
17:41:08 <noway2> I aslo got a list of the server processes, and it looks pretty standard.  It is running Bind as an authoritative master zone.
17:41:41 <Jmainguy> ah nice, forgot about dns. noway2++ fantastic work
17:41:49 <noway2> thank you.
17:42:11 <Jmainguy> I would propose a minimal package set, and then we our user base can email us to ask for installing additional ones
17:42:34 <Jmainguy> I imagine there is cruft on there, and this would be a good way to get rid of packages nobody is using
17:43:36 <Jmainguy> 83% is pretty full, I think we should also set expectations on the website on the amount of disk we imagine our user base should use, with it being a shared resource
17:43:51 <Jmainguy> ie, what is the purpose of a shell account, and proper etiqute of using one
17:44:03 <noway2> I think there is a lot of duplication of web development frameworks, probably outdated. I also wonder if some of the user accounts are long defunct? with a lot of space being occupied.
17:45:01 <Jmainguy> ^^ maybe we spin up the new pilot server, and offer a time frame for people to rsync data over they care about? like a month or two?
17:45:40 <noway2> I like that idea, putting the onus of responsibility to move it or lose it on the user.
17:45:40 <Jmainguy> and ask them to review the TOS before they do, I know for instance there is some content in user dirs, that is breaking the TOS
17:46:44 <Jmainguy> but yeah, this is great progress, a new vm, and working to keep the disk in check are good goals
17:46:54 <Jmainguy> or multiple vm's for splitting the services out as needed
17:47:07 <Jmainguy> I think we still owe you moya access
17:47:21 <Jmainguy> #action Jmainguy will find out how to get on moya, and deliver this information to noway2
17:47:34 <Jmainguy> jeoff: noway2 anything else on this topic before we move on?
17:47:43 <jeoff> Jmainguy: nope
17:47:49 <noway2> Thanks. Is moya the host? It looks like Linode is being used for the authoritative name server.
17:48:08 <Jmainguy> noway2: yeah moya is the physical box that pilot is running on (as far as I know)
17:48:19 <noway2> I am going to put the files on my home dir, you can access... once I get scp to cooperate....
17:48:45 <Jmainguy> noway2: ack, there is a way to use html_pub or something like that in your home dir, which then is web accessible
17:49:03 <Jmainguy> for instance some of our members are breaking the TOS and hosting content that isnt appropriate that way
17:49:15 <Jmainguy> though, not illegal content afaik
17:49:49 <Jmainguy> #topic meetings
17:49:54 <noway2> Not sure... If I were to place a symbolic link in the html directory it would make them accessible.
17:50:18 <Jmainguy> noway2: yeah if you look at the apache config, you can see where it is hosting a special dir in each users home dir
17:50:53 <Jmainguy> so you cna have it in your home dir, in that special directory, and then you can visit it at trilug.org/user-dir/noway2/blah or something like that
17:51:03 <Jmainguy> I would have to look at that apache config to remember how to do it
17:51:34 <Jmainguy> jeoff: you see any blockers to giving your talk in October?
17:51:46 <jeoff> Nope. I'll give a demo mid-late next week
17:51:55 <Jmainguy> jeoff++ ty sir
17:51:58 <noway2> I'll take a closer look at that. I was digging through the apache configs.  There are some old vhosts and things, and I was trying to get a feel for which ones were currently in use.  It looks like some old roundcube and other mail sites used to be in place. Need to take a closer look.
17:52:02 <Jmainguy> I still need to contact Peter about november
17:52:16 <Jmainguy> noway2++ ack, ty ty
17:52:26 <Jmainguy> #action noway2 to dig deeper into the apache configs
17:52:45 <Jmainguy> anything else on the meetings topic before we move on?
17:53:20 <noway2> I'm good.
17:53:48 <jeoff> no
17:53:57 <Jmainguy> #topic general business
17:54:15 <Jmainguy> I am in favor of us getting the 501c3 back, but I am not ready to commit myself to doing that this month
17:54:37 <Jmainguy> at some point this year, we will need to audit all the years we havent filed for, and figure out if we owe uncle sam money or not
17:55:03 <bdmc> Back to the Moya question.  Yes, Moya hosts the VMs, Pilot is one of them.
17:55:17 <Jmainguy> if we do go foward with the 501c3, we should also start doing community out reach, like teaching people how to code or manage unix servers or something
17:55:22 <Jmainguy> bdmc++
17:55:24 <Jmainguy> #chair bdmc
17:55:24 <Tribot> Current chairs: Jmainguy bdmc jeoff noway2
17:55:52 <noway2> I agree, the 501c3 would be beneficial. Couple that with a means to process CC via square like we discussed a couple of weeks ago would facilitate donations. The education would be good. I had a friend the other day say that he wanted to learn how to do server management. I told him to learn Linux and SQL - he thought I was joking.
17:56:05 <Jmainguy> noway2++
17:56:18 <Jmainguy> yeah I would love to be able to help people learn that / offer some resources to help them
17:56:22 <bdmc> As far as money, no we don't owe anything, because our income is too low.  However, there was paperwork ( zero filings ) that should have been done, and because they weren't, we failed out.
17:56:29 <Jmainguy> bdmc++
17:56:37 <Jmainguy> thats good to know
17:56:56 <Jmainguy> just have to sit down and file them at some point, and ask to get reinstated (not retroactive)
17:57:05 <noway2> There was an issue with the registered agent ?? term ... I think someone was filling this roll, but had lost interest and that casued a lot of the upset.  That's going back years though.
17:57:07 <Jmainguy> two seperate things, but on the list of things to do at some point
17:57:27 <Jmainguy> noway2: yeah Jeri the original founder, but now Alan is the agent and is committed to
17:57:33 <Jmainguy> and easy to get in contact with
17:57:43 <Jmainguy> he sees those steering emails and responds sometimes
17:58:09 <bdmc> If you address him directly, he responds quickly.
17:58:21 <Jmainguy> he is like, the best
17:58:26 <Jmainguy> big fan =)
17:58:41 <noway2> I always got a kick out of his handle, Alpo.
17:58:59 <Jmainguy> whenever covid ends, I think it would be pretty cool to get Jeri to come back and give a talk on the original days, that would be awesome
17:59:14 <noway2> jmainguy++
17:59:17 <Jmainguy> or possibly virtual I suppose since she lived in DC 10 years ago, no idea where she living now
17:59:40 <Jmainguy> #action Jmainguy to try and reach out to Jeri about a talk for next year
18:00:03 <Jmainguy> yall got anything else to talk about?
18:00:20 <noway2> Nope.
18:00:30 <bdmc> noway2: Sorry, back to Pilot.  You did recognize that /home isn't home, didn't you?
18:01:43 <bdmc> All of the home directories are under /export, as I remember.
18:02:05 <Jmainguy> /dev/mapper/pilot--vg-home  197G  155G   33G  83% /home
18:02:36 <Jmainguy> /home/trilug on /export/users type none (rw,bind)
18:03:02 <bdmc> Yes, that was it.  Just going by memory.
18:03:55 <bdmc> Anyway, I won't keep you any longer.
18:03:57 <Jmainguy> so its still using /dev/mapper/pilot--vg-home
18:04:07 <Jmainguy> bdmc++ that is good info ty sir
18:04:18 <noway2> Computer froze ...
18:04:21 <Jmainguy> lol nice
18:04:43 <noway2> Yes, I noticed that and saw the NFS or some form of mapping.  It didn't seem to be a big deal, but something to pay attention to in the migration.
18:04:43 <Jmainguy> /home/trilug on /export/users type none (rw,bind) == /dev/mapper/pilot--vg-home  197G  155G   33G  83% /home
18:04:46 <Jmainguy> is about all you missed
18:05:07 <bdmc> Exactly.  And yes, one of our major goals was to replace the OS with something modern, and split it into multiple machines.  ( Keep the "home" directories on a separate machine. )
18:05:20 <Jmainguy> bdmc: thats a good idea
18:05:33 <Jmainguy> be easier to migrate to new vms that way in the future
18:05:39 <bdmc> Right
18:06:00 <noway2> One question that was in the early migration documents was to make /var limited.  I would recommend it as there are some kernel bugs that cause the log files to suck up all the disk space.
18:06:19 <Jmainguy> ^^ I am a big fan of a seperate /var partition, and it doesnt need to be huge
18:06:31 <bdmc> Building a new machine for any of the services, split them out of Pilot while it was still running, would be my recommendation.
18:06:35 <Jmainguy> or atleast a seperate /var/log partition
18:06:40 <bdmc> Jmainguy:  You and me both!!!
18:07:15 <bdmc> I don't understand this "modern" way, going back to the olden days, where everything is in the same partition.
18:08:03 <noway2> That's another thing to document.... If I recall in the PAM auth section there is a mapping of sudo to the root user password, it is something that was definately non standard Ubuntu.
18:08:49 <noway2> That's another question, stay with Ubuntu?  In my experience it makes a pretty solid server that is reliable.
18:09:49 <bdmc> I have been leaning towards Debian lately, but either one.  Doesn't matter to me.  Cristobal and I were trying to upgrade-in-place, which would have been a modern Ubuntu.
18:09:59 <jeoff> gotta go
18:11:37 <bdmc> I think that I have added everything that I need to, for now.  Feel free to contact me, I would like to help, if possible.
18:12:19 <noway2> Ok. I think we've pretty much covered the back end... next time we can discuss the steps of spinning up a new system.
18:13:53 <bdmc> Bye?
18:13:57 <Jmainguy> yeah sorry
18:13:59 <Jmainguy> ty everyone
18:14:04 <Jmainguy> #endmeeting