19:00:58 <justis> #startmeeting
19:00:59 <Tribot> Meeting started Tue Nov  8 19:00:58 2011 UTC.  The chair is justis. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:01:01 <Tribot> Useful Commands: #action #agreed #help #info #idea #link #topic.
19:01:07 <justis> #chair justis alpo coxn
19:01:09 <Tribot> Current chairs: alpo coxn justis
19:01:23 <justis> #topic justis waits for other participants
19:01:41 <justis> fwiw, I hope this meeting is quick
19:04:59 <coxn> reset
19:05:41 <coxn> ooookay
19:05:46 <coxn> now I'm back
19:06:17 <coxn> aaaand I lied
19:06:26 <coxn> I have to go lay hands on a machine to get its serial and whatnot
19:06:27 <coxn> back in 10
19:13:10 <billf> hey
19:13:21 <justis> billf: hey :)
19:13:50 <justis> billf: thanks for processing all those membership applications
19:14:35 <justis> billf: and thanks for http://trilug.org/wiki/Tips_For_Speakers
19:14:49 <billf> no problem
19:15:12 * alpo is here
19:15:39 <justis> #topic general meeting on Thursday
19:15:59 <justis> it looks like Dylan has been preparing ... does anyone have concerns for him that we have not yet raised?
19:16:22 <justis> who is getting drinks?
19:16:25 <justis> who is ordering pizza?
19:16:41 <alpo> i guess i am pizza boy, unless someone else wants it
19:16:45 <justis> anything else we should be considering in advance of Thursday?
19:16:57 <justis> #action alpo to order pizza
19:16:59 <alpo> i should confirm with our pizza sponsors
19:17:06 <justis> alpo: thanks on both those points :)
19:17:14 <alpo> #action alpo to confirm sponsorship with CTG
19:17:35 <alpo> they did not respond before
19:17:56 <alpo> i do not have a good feeling about CTG in general, and specifically this month
19:19:07 <justis> alpo: can you expand on that?
19:20:08 <justis> iirc, snyrk usually gets the drinks?
19:20:21 <alpo> my personal bias - i hate recruiters
19:21:05 <alpo> i know in the past we have had recruiters eager to "sponsor maybe next month" and we never hear from them
19:22:53 <alpo> i sent stephanie a reminder on 10/28, and did not receive any acknowledgement, even a "k"
19:23:59 <justis> alpo: ick, ok
19:24:10 <justis> well, our members are the most reliable pizza sponsor we have
19:24:14 <justis> I'm glad that we have them :)
19:24:20 <alpo> and them, us
19:29:17 <justis> #action snyrk to get drinks for Thursday
19:29:26 <alpo> crafting a carefully worded "assuming your offer still stands" letter for CTG
19:29:28 <coxn> aaand I'm back
19:29:52 <justis> #topic updates for pilot
19:30:11 <alpo> we desperately need to upgrade to 10.04LTS
19:30:19 <justis> coxn: o/
19:30:26 <justis> alpo: agreed
19:30:27 <coxn> yeah that's me
19:30:28 <alpo> but we had been holding off because of our degraded RAID
19:30:48 <coxn> so do we need to buy drives?
19:30:52 <coxn> or what do we need?
19:30:56 <justis> what kind of guild are we if we can't do a raid?
19:30:56 <alpo> we just need to reconfig what we have
19:31:05 <coxn> do I need to more agressively take point on this?
19:31:11 * coxn chuckles at justis
19:31:16 <justis> coxn: :)
19:31:33 <justis> coxn: I encourage you take point on this. We need someone to own it.
19:31:36 <coxn> also, unrelated to the do-release-upgrade...
19:31:41 <coxn> shall we go ahead and do the kernel update?
19:31:47 <alpo> i attempted to pvmove our stuff to the lonely unused RAID array, and that locked up pilot
19:31:52 <coxn> if so, is Friday at 4pm good?
19:32:14 <alpo> i am not as concerned with the kernel update as I am about 10.04
19:32:23 <alpo> (since we're still on 8.04)
19:32:59 <justis> these are the packages scheduled for upgrade: linux-image-2.6.24-29-server linux-libc-dev tzdata
19:33:17 <coxn> good lord we're so far back
19:33:36 <justis> alpo: idk, kernel updates on an older LTS may be pretty important
19:33:45 <alpo> sure, they are
19:33:59 <justis> #action coxn to upgrade kernel on Friday at 4pm
19:34:09 <justis> Friday is good. It allows us to announce it at the meeting.
19:34:22 <alpo> so beyond the small patch
19:34:29 <alpo> when can we look at a proper ugrade?
19:34:39 <justis> #action coxn to send email today announcing Friday's kernel upgrade
19:34:47 <alpo> it makes sense to fix the RAID and upgrade to 10.04 at the same time
19:35:11 <coxn> alpo: you have any time this weekend?
19:35:33 <coxn> I'm happy to be copilot for such an endeavor
19:35:43 <coxn> esp. this weekend
19:35:46 <alpo> i could work on it on sat AM
19:36:05 <coxn> if we do that, I'll make a big announcement for a four-hour downtime or somesuch
19:36:15 <coxn> instead of a small announcement for a Friday kernel patch
19:36:43 <coxn> 8:30am too late to start?
19:36:55 <alpo> does this need to be on site?
19:37:52 <alpo> if i can get a console and/or a reset switch from dargo or rygel, then i am OK doing it remotely
19:38:55 <justis> if you guys can describe a simple and compelling rollback option, then I think Saturday is good
19:39:32 <coxn> justis: "rollback" is new install instead of upgrade
19:39:48 <alpo> my plan would be to pvmove off of the degraded array, take it out of the LVM volume group, potentially back up /, then upgrade using do-release-upgrade
19:39:54 <coxn> alpo: if you're comfortable with that and you can help me get a console, I'm comfortable with it
19:39:57 <coxn> but I had assumed on-site
19:40:07 <alpo> on-site works, too
19:40:54 <alpo> because i would hate to lose time just screwing around trying to get a console or to reset
19:41:20 <alpo> plus, i could bring in a USB drive to back up /
19:41:40 <billf> just warn all users to backup their files before the upgrade
19:41:47 <coxn> yeppers
19:42:03 <coxn> okay so... are we agreed on a downtime starting at 8:30am local on Saturday?
19:42:03 <billf> and we need to make sure we have backups of the ldap and mailman databases
19:42:09 <coxn> and alpo and I will be on-site?
19:42:12 <alpo> heck /home is only 200G
19:42:20 <coxn> and he and I will work out all the details in the nearish future?
19:42:29 <coxn> and I'll send out an announcement this afternoon?
19:44:18 <coxn> going once...
19:44:24 <justis> if it's important for users to backup their own data before this upgrade, then we should give at least 14 days notice
19:44:35 <billf> can we backup pilot data onto rygel's disk before the upgrade ?
19:44:41 <justis> if we trust our own backups, then let's do it
19:44:42 <alpo> rygel's disk is too small
19:44:44 <coxn> if we're on-site, we can do it with an external drive
19:45:23 <alpo> agreed
19:45:25 <billf> if you use an external drive, start the backup a couple of days prior so your not waiting around
19:46:21 <alpo> i suppose i could starn an rsync tonight
19:47:52 <alpo> task added to my calendar for tonight
19:48:11 <justis> #action alpo to start an rsync backup in advance of the upgrade
19:48:51 <billf> could we add bigger disk to rygel so we can rsync pilot ?
19:49:03 <coxn> cool... did we already get the action for me for announcement today and work on Saturday?
19:49:10 <justis> #action coxn to send announcement today about an upgrade to 10.04LTS on Saturday morning
19:49:15 <coxn> and do we have anything left that we haven't come to consensus on?
19:49:26 <justis> #action coxn to upgrade us to 10.04LTS on Saturday
19:49:34 <justis> #action alpo to help coxn with upgrade on Saturday
19:49:34 <billf> drinks ?
19:50:21 <coxn> #topic drink
19:50:33 * justis is thirsty
19:51:57 <justis> does anyone have a link handy for the poll?
19:51:58 <coxn> okay I finally did the poll
19:52:08 <justis> coxn: were you the last one?
19:52:12 <coxn> #link  http://www.congregar.com/vote/82n4vcdoxom1vhasany0ba6hx/
19:52:16 <coxn> possibly?
19:52:19 <coxn> I didn't check
19:52:59 <justis> hey look ... all 5 of us are available both this weekend and next weekend
19:53:15 <billf> I nominate Sunday 13th Nov
19:53:36 <billf> the longer we leave this the tighter my calendar gets
19:53:48 <alpo> assuming coxn and I are done with the upgrade after 36 hours... sure
19:54:07 <billf> might be good for a debrefe
19:54:20 * alpo is keeping his briefs on, thank you
19:54:28 <billf> I could do Sat miday
19:54:53 <alpo> can we bring beer to SunGard ?
19:55:01 <billf> Thats the problem with these polls, they need time blocks
19:55:08 <billf> no liquid in the server room
19:55:14 <alpo> days = large blocks
19:55:22 <justis> yeah
19:55:28 <justis> well, I'm open all day on both days
19:55:42 <justis> there's some stuff going on at SplatSpace that I might check out
19:56:11 <justis> one of our members is reinstalling asterisk and has offered to make it a mini-workshop and to answer questions
19:56:16 <alpo> sun evening ?
19:56:20 <justis> and a couple others are working on the Google AI challenge
19:56:30 <justis> sure, Sunday evening works
19:56:43 <alpo> (ooh, asterisk)
19:57:12 <billf> I'm not against meeting at SplatSpace on Sun if that works out better. Otherwise pick a pub
19:59:44 <justis> coxn: what's your transportation situation on Sunday?
20:00:13 <alpo> if transport is a problem, i can do some shuttling
20:00:19 <alpo> sat or sun
20:01:35 <coxn> Sunday?
20:01:39 <coxn> you mean Saturday?
20:01:42 <coxn> sorry for the delay
20:01:52 <justis> coxn: upgrade on Saturday; drinks on Sunday
20:01:58 <justis> coxn: unless you want to vote otherwise
20:02:07 <coxn> both sound fine
20:02:10 <coxn> I can borrow a car
20:02:11 <billf> or we just do it all on Sat
20:02:18 <coxn> either way
20:02:23 <alpo> if cars are a problem we can do both on sat
20:02:23 <coxn> somebody just ping me with the results
20:02:44 <coxn> (sorry... trying to do three things at once)
20:02:45 <alpo> ok, i'll break the log jam with a vote for sunday evening
20:03:14 <justis> do we also want food or is it just drinks?
20:03:30 <alpo> food is OK
20:03:43 <coxn> if evening, I vote food also
20:03:46 <coxn> and not just drinks
20:05:40 <alpo> ok, place?  splatspace?  some place we voted on before, in carrboro?
20:05:55 <alpo> jeff's apartment?
20:06:16 <coxn> obviously I have a preference for Carrboro
20:06:22 <coxn> because that would mean no need for a car on Sunday
20:06:30 <coxn> but I'll make wherever work
20:06:38 <billf> coxn: can you pick a place in Carrboro
20:06:50 <billf> I don't know the area
20:07:26 <alpo> ok, suggestions to follow via email and on thu night meeting
20:07:33 <coxn> three places I'll suggest: (1) Milltown, (2) Southern Rail, and (3) Carolina Brewery
20:07:41 <justis> for food, I recommend Dos Taquitos
20:07:52 <coxn> the first two have the edge on the food, but are also marginally more expensive
20:07:57 <justis> but I'll eat in Carrboro
20:08:00 <coxn> Milltown has the best beer selection
20:08:09 <coxn> CB brews its own
20:08:24 <coxn> Southern Rail has the novelty of being in a rail car
20:08:29 * coxn shrugs
20:09:03 <billf> they all sound good, we will decide via email then
20:09:32 <alpo> yes, and let's adjorn soon
20:10:01 <billf> I will bring the box and last months money on Thursday
20:10:19 <justis> billf: thanks :)
20:10:38 * justis got sucked into helping another developer with something ... still thirsty, tho
20:12:12 * alpo is off to solve a software bug
20:13:04 <justis> alpo, billf, coxn: thanks ... have a great day :)
20:13:09 <justis> #endmeeting