19:00:38 <justis> #startmeeting
19:00:38 <Tribot> Meeting started Tue Dec 13 19:00:38 2011 UTC.  The chair is justis. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:00:39 <Tribot> Useful Commands: #action #agreed #help #info #idea #link #topic.
19:00:55 <justis> #chair alpo billf coxn
19:00:56 <Tribot> Current chairs: alpo billf coxn justis
19:00:58 <coxn> yo
19:01:05 <justis> coxn: yo :)
19:01:21 <coxn> not sure what you mean by admin rights
19:01:28 <coxn> everything goes by supybot config
19:01:39 <justis> #topic Alex Meadows presents on Business Intelligence
19:02:00 <justis> coxn: I'll get you on side channel about tribot
19:02:06 <coxn> cool
19:02:43 <billf> bool
19:03:34 <justis> !bool
19:04:17 <justis> so, everyone check recent mail to steering@trilug.org to see my discussion with Alex. He's open to many subtopics about BI and wants us to specify which parts would most interest the LUG
19:07:21 <justis> snyrk: o/
19:09:23 * snyrk waves then scampers off to avoid setting his kitchen on fire
19:17:01 * justis harmonizes with the crickets
19:17:12 <justis> billf: any input about Alex Meadows?
19:17:44 <billf> justis: I still have no idea what BI is or how it impacts me
19:22:25 <snyrk> i tend to feel the same way
19:22:39 <snyrk> which makes the topic intriguing
19:22:54 <coxn> I have a vague notion only because I've had to stand up machines on which BI software will run
19:23:06 <snyrk> though it might require a carefully written bit of text when we announce the talk
19:25:32 <justis> hrm
19:25:42 <justis> BI may be too large of an umbrella
19:25:53 <justis> perhaps we should talk about some of the parts under the umbrella that Alex knows
19:26:01 <justis> and see if any ring true for you guys
19:26:16 <justis> data warehousing?
19:26:20 <coxn> I'd like to add a topic to the stack for once we're done with setting up the BI talk...
19:26:21 <snyrk> overview + some grounding specifics is always something i favor
19:26:24 <justis> data analysis?
19:26:29 <justis> data mining?
19:26:31 <coxn> and that's snyrk teaching us how to deal with wikispam
19:26:40 <justis> coxn: lol
19:26:43 <snyrk> wut?
19:27:01 <snyrk> were we spammed again?
19:27:04 <coxn> yes
19:27:05 <coxn> same page
19:27:12 <justis> performance dashboards?
19:27:18 <coxn> but... let's deal with that after this, yeah?
19:27:22 <coxn> sorry to derail
19:27:30 <snyrk> agreed
19:27:48 <snyrk> datawarehousing sounded like a good direction
19:27:56 <snyrk> what's the premier OSS package in that space?
19:27:59 <coxn> okay so... I agree with snyrk that an overview is good
19:28:18 <coxn> and then focus on some subtopic
19:28:21 <justis> Ok. I'm going to ask him to spend 20 mins doing an overview of BI in general.
19:28:21 <snyrk> yup yup
19:28:25 <justis> best subtopic?
19:28:41 <coxn> +1 for datawarehousing
19:28:43 <justis> plz read intro to http://en.wikipedia.org/wiki/Business_intelligence (before the TOC)
19:29:40 <coxn> interesting
19:29:57 <justis> snyrk: data warehousing requires a DBMS and an ETL tool. Most people use whatever DBMS they use for the rest of their stuff. I'm not sure which ETL tool Alex uses, but I suspect it's the one that Pentaho offers.
19:30:20 <snyrk> pentaho is a suite, then?
19:30:54 <snyrk> wikipedia article just proves how fuzzy this topic feels from the top
19:31:13 <justis> snyrk: Correct. That's why both Alex and I want some direction on where to focus.
19:32:27 <justis> snyrk: Yes. Pentaho offers a suite of BI tools. I'm pretty sure that ETL is one of their offerings.
19:32:50 <justis> fwiw, ETL can be done by hand for simple data warehousing
19:33:24 <justis> http://en.wikipedia.org/wiki/Extract,_transform,_load
19:33:42 <snyrk> given that those are both Alex's self-proclaimed areas of expertise, i don't see why they wouldn't be our top choices
19:34:25 <justis> cool
19:36:04 <coxn> so... anything else we need to cover on the BI front?
19:36:05 <snyrk> perhaps we should ask alex for a quick outline off the top of his head?
19:36:17 <snyrk> and then decide if it seems too broad or narrow?
19:36:28 <snyrk> ETL + DW outline, that is'
19:39:10 <justis> snyrk: yeah, sounds good
19:39:34 <justis> I will want him to do at least a whirlwind tour of analysis services on top of an OLAP cube
19:39:45 <justis> to me, it's the ultimate magic of BI
19:40:05 <justis> it allows you to "slice and dice" data across many different dimensions
19:40:27 <justis> like finding the top selling item for a region during a particular season
19:40:44 <justis> or finding the worst selling item globally and then finding the stores that do the best at selling it
19:41:07 <justis> it could be really powerful when applied to system performance data or network traffic
19:41:41 <justis> aggregates about protocol usage, bandwidth, etc
19:42:20 <snyrk> well, there's no doubt our future is going to be filled with more data than we know what to do with
19:42:41 <justis> for better or for worse
19:43:00 <snyrk> inevitable, so we better learn to deal
19:43:03 <justis> true
19:43:11 <justis> ok, I think that I'm ready to coordinate with Alex
19:43:15 <justis> any parting comments?
19:43:55 <coxn> well, can we cover the spam issue?
19:43:58 <coxn> #topic wikispam
19:44:18 <justis> coxn: that's what I was getting ready to do. I was trying to capture closing comments on the previous topic.
19:44:20 <coxn> snyrk: can you send us a quick howto on reverting pages like that Talk page that got hit again?
19:44:27 <coxn> oh. sorry. :(
19:44:51 <justis> coxn: No worries. You were half the people I was waiting on and the other half (billf) is idle.
19:44:52 <coxn> I couldn't find a radio button, revert link, etc.
19:45:07 * snyrk looks around at the snyrk who actually has a clue about mediawiki
19:45:28 <snyrk> if it's a new page, there is no revert
19:45:30 <snyrk> just delete
19:45:30 <coxn> was it some other Jeff?
19:45:40 <coxn> fair enough
19:45:52 <snyrk> that may be the sum total of my knowledge on the subject =)
19:45:56 <coxn> heh
19:46:13 <snyrk> that said, i do think it would be worth looking at a question-based captcha
19:46:15 <coxn> well... we'll cover that again later... after some research, possibly
19:46:42 <billf> did something get through our wiki protection ?
19:46:45 <snyrk> "What's the L in TriLUG stand for?" was the popular example
19:46:52 <snyrk> billf: yup, twice now
19:47:05 <snyrk> they're registering for accounts through recaptcha
19:47:40 <billf> Do we still have the http auth login ?
19:47:45 <snyrk> no
19:47:59 <snyrk> that very heavy hammer actually does work
19:48:03 <billf> no wonder
19:48:19 <billf> if only it was for edits
19:48:37 <billf> and we could have unfettered read access
19:50:13 <snyrk> our old HTTP auth was basically nothing more than question based verification
19:50:24 <snyrk> no reason not to plug it into the correct part of the architecture
19:50:42 <snyrk> i just need to dig up a compatible plugin
19:51:39 <snyrk> so, i'll do that and get back to everyone
19:51:48 <snyrk> unless there is a counter proposal
19:52:37 <justis> snyrk: make it so :)
19:52:54 <justis> #action snyrk to add question-based verification to wiki
19:53:02 <justis> snyrk: thx for volunteering
19:53:19 <justis> are we done with wikispam topic?
19:54:14 <snyrk> not yet...
19:54:17 <snyrk> php sucks
19:54:19 <snyrk> ok done
19:55:12 <justis> lol, nice
19:55:31 <justis> #action snyrk to avoid PHP's event horizon
19:55:44 <justis> #topic who talks in January?
19:55:59 <justis> I just got reply from Lisa. She's also available to talk in January. Which topic do we want first?
19:56:21 <justis> fwiw, she's probably the more difficult one to schedule
19:56:23 <justis> she travels a lot
19:57:53 <snyrk> do we have any other factors to weigh?
19:58:22 <snyrk> alex seems... easy to get a response from
19:58:42 <justis> at the Dec meeting, I spoke some with Barry. He's a grad student at NCSU and is doing research that involves trusted computing. He had some neat examples to share about user-empowering uses of trusted computing and said that he could speak for ~20 mins about it
19:59:00 <justis> snyrk: yeah, I love how quickly Alex replies
19:59:17 <justis> also, Barry offered to speak for ~20 mins about USRP
19:59:33 <justis> which I really want as part of our three-speakers-for-one meeting
20:00:08 <justis> maybe with Jeff Crews as another 20 mins, talking about MakerBot, Mantis mill, etc (3D CNC)
20:00:29 <billf> at least the linux software that runs the mill
20:00:30 <snyrk> USRP? the radio?
20:00:35 <justis> snyrk: yes :D
20:01:27 <justis> I'm thinking those two topics with a third speaker (maybe me) talking about open source hardware and how its current state relates to open source software in the 80s
20:02:09 <snyrk> too bad adafruit and sparkfun aren't located nearby
20:02:22 <justis> e.g. very few clear leaders, fractured landscape, lots of interesting action, lots of potential for future growth, important opportunities to keep things open that are otherwise destined to be closed
20:02:43 <justis> snyrk: it wouldn't suprise me if one of them would split the costs with us for importing a speaker
20:02:53 <justis> more likely to be SparkFun
20:03:03 <justis> but Lady Ada would sure draw a crowd
20:03:18 <snyrk> i think i saw a talk by the sparkfun founder online a bit back
20:03:51 <snyrk> either would be great, and we could draw in a huge crowd from various groups
20:03:52 <justis> anyhow ... I think this 3-for-1 meeting takes more prep. Let's save it for Feb or Mar. I was bringing it up only because Barry might contribute to both.
20:04:04 <snyrk> put him on the list
20:04:12 <snyrk> i started reworking the wiki page a bit
20:04:17 <snyrk> but it still needs love
20:04:24 <justis> Jan = Lisa+Barry ... or Alex?
20:04:36 <snyrk> does Lisa want a co-speaker?
20:04:41 <justis> idk, I'll ask her
20:04:50 <snyrk> probably a good place to start
20:04:51 <justis> she's welcome to incorporate Barry's stuff herself
20:05:06 <justis> I really like that he had a concrete example of trusted computing used for good instead of evil
20:05:11 <justis> related to locally relevant research
20:05:27 <snyrk> indeed
20:05:52 <snyrk> the example and perspective are welcome whoever presents it
20:06:00 <justis> agreed
20:06:28 <justis> fwiw, Barry is one of the "junior speakers" that I want to make sure the LUG nurtures
20:06:48 <justis> anyhow ... which topic for Jan? BI or TCG?
20:07:01 <snyrk> TCG, unless alex explicitly can't do 2/9
20:07:07 <justis> ok
20:08:16 <justis> #action justis to get both Lisa and Alex committed to specific dates
20:09:44 <snyrk> next up... pilot rebootage?
20:10:27 <justis> #topic pilot reboot
20:11:50 <snyrk> so, apparently we need to do one
20:14:21 <snyrk> assuming we shoot for 5:00p tomorrow, volunteers to get a notice out before 5 tonight?
20:15:43 * snyrk stares at the ceiling, whistles badly
20:17:27 <snyrk> a'ight... i gots things to do
20:17:42 <snyrk> i'll send out an announcement and reboot tomorrow
20:18:01 <snyrk> scream in the next hour if you think this a bad idea
20:18:12 <justis> snyrk: I think it's a good idea
20:18:17 * justis was busy following up with speakers
20:18:35 <justis> coxn: ping
20:18:45 <justis> alpo: ping
20:18:47 <justis> billf: ping
20:18:53 <justis> any objections to reboot tomorrow night?
20:19:35 <alpo> ooh, i bet we had a meeting, didn't we ?
20:22:25 <billf> reboot whenever.
20:22:35 <justis> cool
20:22:46 <billf> the reboot email should state what we are upgrading from and to
20:22:58 <justis> #action snyrk to send announcement about reboot
20:23:31 <justis> snyrk: thanks for volunteering; please let us know if you're overloaded
20:23:38 <justis> #topic any remaining agenda?
20:23:39 <snyrk> nope, just a sucker
20:23:42 <justis> alpo: ?
20:23:44 <justis> billf: ?
20:24:13 <snyrk> billf: i think i'll focus on getting the date and time right for once
20:24:19 <alpo> ok, i was catching up on the emails
20:24:57 <alpo> that entire discussion with Alex Meadows went over my head
20:25:31 <alpo> the one with Lisa Lorenzin pretty much did, too
20:25:37 <justis> lol,k
20:25:47 <justis> I hope that both their talks are able to solve that problem
20:26:34 <billf> I would like to have a trilug hack day / installfest sometime
20:26:49 <justis> #topic trilug hack day
20:27:00 <justis> billf: can it be on a day other than 2nd Thu?
20:27:11 <billf> weekend pls
20:27:14 <justis> SplatSpace is glad to host. I suspect we could get space from RedHat or NCSU, too
20:27:31 <justis> billf: Sat or Sun? Morning, afternoon, or evening?
20:27:42 <justis> if it's weekend, then SplatSpace might be easier
20:27:45 <justis> since I have a key
20:27:59 <billf> either Sat or Sun, just need a location with networking
20:28:12 <justis> billf: topic nominations?
20:28:33 <billf> plat space might work, otherwise Techshop might let us use the conference room
20:28:57 <justis> TechShop has the benefit of already having someone at the front desk
20:28:58 <billf> we should theme it
20:29:02 <alpo> (but I will be in China during the January meeting)
20:29:05 <justis> what theme?
20:29:18 <justis> alpo: Which meeting would you rather not miss?
20:31:11 <billf> snyrk: any themes from this years survey ?
20:32:16 <billf> How about "network of things"
20:32:17 <snyrk> i think the general theme was "yes, please!"
20:32:22 <alpo> i need to duck out...
20:32:28 <snyrk> but i'd have to dig through the comments again to get any specifics
20:33:09 <billf> A) Web tech - cgi scripts, html5, ruby
20:33:40 <billf> B) Linux Media servers, mythtv, xbmc, etc
20:34:31 <billf> C) network tools, emulation, wizardry
20:34:54 <billf> D) OpenWRT installfest and customising
20:35:25 <billf> PS: these are the topics I am currently doing/interested in
20:35:57 <billf> So let's churn on this, need a place/date/time first
20:38:17 <justis> billf: should we do a survey / google moderator / etc to see which topic would draw a larger crowd?
20:38:27 <justis> re place/date/time, how soon?
20:38:31 <justis> Feb? Jan?
20:38:36 <billf> No, too much stuffing around, just do it.
20:38:50 <billf> Jan would be better.  There is FOSS day at NCSU in Feb.
20:41:02 <billf> we might be able to do it in conjunction with ncsu's lug
20:43:41 <justis> billf: if you don't want a survey, then just pick the topic
20:43:56 <justis> if you do C, you'll get nivex
20:44:16 <justis> if you do A, you'll get lots of people and there is likely to be zealotry
20:44:40 <justis> I suspect that D would get a medium sized crowd and people would walk away with a sense of accomplishment
20:45:04 <justis> I can't predict how B would play, but I'm still curious about it
20:45:25 <justis> #action billf to pick a topic for hack session
20:45:31 <justis> that's all the input I have
20:45:55 <billf> Option D is probably the best.  Covers recent ml discussions too
20:46:38 <justis> nice
20:47:12 <billf> So location...
20:47:15 <justis> if it were me, I would use doodle.com to find the date when enough people want to show up to said event
20:47:28 <justis> but billf might say that's 'too much stuffing about'
20:47:53 <justis> I'm neutral on location, with a slight leaning toward TechShopRDU
20:47:59 <justis> for simplicity of door access
20:48:01 <billf> yeah, sometimes it is better to just drive a stake in the ground and announce a firm date
20:48:12 <justis> with big meetings, sure
20:48:23 <justis> with special interest meetings, you want the right date with committed parties
20:48:33 <billf> I will look into TS dates and ask them if we can do it.
20:48:42 <justis> you don't need to pick the date when everyone can make; you just need the date when lots of people can make it
20:50:20 <billf> OK, it's almost 4pm, I have to get on with things here :-(
21:05:19 <justis> billf alpo coxn snyrk: thanks for your contributions
21:05:24 <justis> #endmeeting