02:00:07 <billf> #startmeeting
02:00:08 <Tribot> Meeting started Tue Sep 18 02:00:07 2012 UTC.  The chair is billf. Information about MeetBot at http://wiki.debian.org/MeetBot.
02:00:09 <Tribot> Useful Commands: #action #agreed #help #info #idea #link #topic.
02:00:17 <alpo> just catching up on "Draw Something" and "Words with Friends" with my parents
02:00:32 <billf> #chairs justis coxn alpo
02:00:43 <billf> anyone seen jeremy tonight ?
02:00:51 <jeremyhwllc> here
02:01:04 <alpo> drawsome!
02:01:07 <alpo> (sorry)
02:01:47 <billf> #chairs justis coxn alpo jeremyhwllc
02:01:57 <billf> welcome everyone
02:01:58 <jeremyhwllc> just went to the dc919 first meeting at Splatspace in Durham. I saw some of our finest speakers there
02:02:14 <justis> dc919?
02:02:21 <billf> what are they planning as dc919
02:02:23 <jeremyhwllc> Def Con
02:02:32 <justis> wow
02:02:39 <justis> is this a new thing?
02:02:53 <jeremyhwllc> today was to organize
02:02:54 <billf> yeah, but why a splatspace group ?
02:03:29 <jeremyhwllc> Ronin and Lisa were there and some folks I did not recognize
02:04:50 <jeremyhwllc> dc919.org
02:05:03 <billf> #topic October Meeting
02:05:32 <coxn> jeremyhwllc: you have the text to add to the announcement this time, yeah?
02:05:55 <coxn> I think the kids thing worked well. We had several and all the parents were well-behaved
02:06:11 <jeremyhwllc> ya
02:06:16 <justis> coxn: *awesome*
02:06:38 <coxn> :)
02:06:52 <coxn> good good. maybe I'll note that that worked well on the list
02:07:04 <justis> whoa ... text contrast fail on http://dc919.org/
02:07:17 <coxn> jeremyhwllc: thanks in advance for including that text in the October announcement, then.
02:07:33 <jeremyhwllc> sorry I missed it last time
02:07:54 <coxn> no worries
02:08:08 <billf> ok, so we have a speaker, do we need to review his slides ?
02:08:23 <alpo> if we're ready with initial meeting text, we could post the october announcement to drupal ??
02:08:29 <jeremyhwllc> I need to get his slide actually
02:08:44 <justis> billf: is he an experienced speaker?
02:09:07 <jeremyhwllc> I pinged them again tonight to make sure they were good with the announcement
02:09:18 <justis> has he used this same slide deck elsewhere or is it brand new?
02:09:48 <coxn> is this the Todd Lewis who works at UNC?
02:10:06 <jeremyhwllc> No , he is the founder of POSSCON
02:10:21 <coxn> okay. I thought so, but suddenly I was unsure
02:11:35 <jeremyhwllc> Todd will speak briefly for about 15-20 minutes then Jim Salter will do a KVM talk
02:12:02 <coxn> so jeremyhwllc are you pinging them about slides?
02:12:10 <jeremyhwllc> yes
02:12:22 <coxn> cool. we need anything else for Oct?
02:12:30 <billf> sponsor ?
02:12:34 <alpo> i pinged brenda at peak10
02:12:37 <alpo> no word yet
02:12:40 <billf> ok great
02:12:51 <billf> workshop for oct ?
02:13:21 <coxn> what's the question?
02:13:41 <billf> do we want to run a workshop for Oct, if so what topic ?
02:13:49 <billf> and who would like to run it ?
02:13:52 <justis> KVM?
02:13:56 <jeremyhwllc> Not sure, I did not discuss that with Todd or Jim
02:14:11 <justis> if they're from out of town, asking them to do a workshop is a bit much
02:14:12 <jeremyhwllc> They are traveling over 3 hours
02:14:26 <justis> but we have plenty of members who know KVM
02:14:30 <coxn> yeah I think we'd have to run it ourselves
02:14:36 <justis> the presenter doesn't have to be present for a workshop to be useful
02:14:39 <coxn> if we wanted to do a workshop on kvm
02:14:44 <alpo> do we need to help them with gas money ?
02:14:57 <justis> alpo: it would be a good gesture, which we can afford
02:15:00 <billf> we don't need to do kvm at the workshop
02:15:10 <justis> billf: fair point
02:15:29 <justis> do we *need* to do a workshop?
02:15:43 <jeremyhwllc> I will find out about gas money, workshop, slides
02:15:50 <coxn> hey I just saw an email response from Todd
02:15:56 <coxn> includes bios; awesome
02:16:12 <coxn> so looks like we're go for a drupal post
02:16:28 <billf> we don't *need* a workshop.. but they do help build a community
02:18:01 <billf> Anyone on the SC want to run a workshop on *something* in October ?
02:18:39 <billf> shall I ask for a volunteers on the general list ?
02:18:45 * alpo feels like workshops are good when they complement the meeting, but does not feel pressure to do them on their own
02:18:55 <justis> idea, not necessarily for October: let's ask NCSULUG if any of their members would like to run a workshop on something
02:19:20 <billf> nscsulug has started running "hackdays"
02:19:40 <justis> also, let me know if you think of other ways you'd like to cross-pollinate with NCSULUG. I am bumping into them more often lately.
02:19:40 <coxn> maybe they'd do a hackday on virt-manager
02:19:46 <coxn> or some other part of the public stack
02:20:04 <justis> although, they meet on Tuesdays and I can't do Tuesdays :(
02:20:05 <coxn> do they have something scheduled for October?
02:20:16 <coxn> hackday-wise?
02:21:15 <coxn> looks like they don't have anything on their calendar
02:21:17 <billf> no idea
02:21:26 <billf> #topic Request for OpenShift tools install (ruby) on pilot ?
02:21:33 <coxn> justis: would you be willing to ping them about making their ... wtf?
02:21:41 <coxn> umm. okay
02:21:57 <billf> wtf??
02:22:11 <coxn> we just changed topics
02:22:13 <billf> sorry, did I move ahead too fast ?
02:22:23 <coxn> I thought you wanted to talk about doing something in October
02:22:41 <coxn> but we can talk about this if you want to leave that to another steering meeting
02:23:06 <coxn> I was just going to propose that we talk to ncsulug about doing a kvm-related hackday in October
02:23:23 <billf> well, we have some ideas, some rabbits to chase.  perhaps we should do action items
02:23:43 <billf> yep, sounds like a good idea.
02:24:09 <coxn> okay.
02:24:19 <coxn> shall I do the pinging, or do you want to do it, justis?
02:24:34 <justis> I'll ping Barry about it
02:25:04 <justis> #action justis to ask Barry Peddycord about NCSULUG and TriLUG co-branded workshops
02:25:23 <justis> re openshift tools: yes, install them
02:25:25 <alpo> so... what is this about openshift tools?
02:25:43 <coxn> how do openshift projects get deleted?
02:25:53 <alpo> who is requesting the tools?
02:25:59 <coxn> how do we make sure that our paltry RAM isn't eaten up?
02:26:09 <alpo> the summary of the meeting preso was to get started using the livecd
02:26:10 <justis> passing thought I had about this, though ... it seems like it would be neat on multiuser systems to have something like "apt-get request-install foo"
02:26:13 <billf> there was an email to the sc 2 weeks ago
02:26:22 <justis> coxn: this is for remote control of openshift instances that aren't on our systems
02:26:34 <coxn> ahh
02:26:38 <alpo> ah, a client
02:27:02 <coxn> so I should go look at the slides for the openshift talk to see what I'm doing, or...
02:27:05 <coxn> ?
02:27:13 <coxn> and presumably I'm the one installing?
02:27:35 <justis> iirc, the requestor provided a link to the tools
02:27:52 <justis> afaict, they're ruby scripts that act as an http client to a web service
02:28:03 <justis> should be low risk and low RAM, short-lived processes
02:28:13 <justis> it's not in apt, tho
02:28:16 <alpo> ok, so this was from william chandler on 8/30
02:28:21 <justis> not sure if there's a .deb floating around somewhere
02:28:27 <alpo> and he says he has a work-around, to use the tools from home
02:28:28 <coxn> I don't know that I ever saw the original request
02:28:33 <alpo> so it's a very low priority
02:28:33 <coxn> was this on the mailing list?
02:28:44 <alpo> on the steering list
02:28:51 <alpo> subject = "Install Software on Pilot"
02:29:49 <coxn> I see it now
02:30:29 <coxn> so do we want to do this for this user?
02:30:34 <justis> yes
02:30:51 <coxn> okay
02:30:57 <justis> he's a longtime member, provides useful posts on trilug@trilug.org, and it's low risk
02:31:13 <coxn> that's two ayes and no opposition
02:31:15 <coxn> I'll install ruby
02:31:17 <coxn> and the gem
02:31:25 <justis> coxn: thanks :D
02:31:36 <billf> #action coxn to attempt install of OpenShift ruby tools
02:31:45 <billf> #topic GoDaddy as our registrar - can we move ?
02:31:57 <justis> GoAwayDaddy
02:32:00 <billf> s/can/should/
02:32:02 <alpo> email wcchandler@gmail.com if you have questions
02:32:17 <alpo> i see no reason to switch registrars...
02:32:23 <billf> is this something we should think about ?
02:32:28 <alpo> we are registered for a long time, 10 years if i recall
02:32:42 <billf> didn't GoDaddy support SOPA ?
02:33:31 <jeremyhwllc> yes
02:33:33 <justis> I think that all registrars suck, just some suck less. GoDaddy has always sucked more, IMO.
02:33:43 <alpo> 5-year registration, due in 2013.
02:33:44 <coxn> GoDaddy sucks; moving is a pain
02:33:55 <justis> I also think that moving isn't particularly important.
02:34:00 <alpo> i have moved several to namecheap, no complaints
02:34:12 <coxn> shall we punt this to the 2013 SC? ;)
02:34:13 <alpo> shall we consider moving when 2013 rolls around ?
02:34:14 <justis> if you're going to move, move before the date
02:34:19 <coxn> ^5 alpo
02:34:31 <billf> move well before the expiry
02:34:33 <coxn> fair enough
02:34:44 <alpo> Expiration Date:16-Nov-2013
02:34:55 <alpo> i will make a note on https://steering.trilug.org/wiki/index.php/ExternalServices
02:35:03 <justis> the pro-rated value of the few months isn't much compared to the value of our time and it's risky to move too close to expiration
02:35:09 <justis> maybe move it during the summer of next year
02:35:19 <alpo> agreed
02:35:31 <coxn> May is elections
02:35:33 <jeremyhwllc> new year resolution?
02:35:36 <billf> ok
02:35:51 <coxn> maybe our final act for this SC?
02:35:58 <coxn> either way; later.
02:36:09 <billf> #topic Sungard Hosting - clearing up Kevin's issue ?
02:36:25 <jeremyhwllc> Kevin's issue?
02:36:51 <billf> kevin started asking our hosting facility if they have ipv6 yet
02:37:01 <jeremyhwllc> ahh
02:37:31 <billf> the support desk couldn't find our account or contact person, so he was starting to smell something fishy
02:37:32 <jeremyhwllc> do they not?
02:37:40 <coxn> at one point somebody at Sungard (sp?) asked if we have an invoice
02:38:01 <coxn> that's the sort of question you ask when you smell a rat
02:38:09 <coxn> so I think we should be careful
02:38:09 <alpo> they do that every time... the support droids have a script, and we have no proper account
02:38:15 <billf> I don't care about the ipv6 at this stage, but I don't want red flags going up
02:38:55 <billf> what is our relationship with sunguard, who is our point of contact ?
02:39:39 <coxn> we got hosting donated with no firm paperwork or bounds or whatever from whatever the entity was that had the facility before Sungard
02:39:43 <coxn> Sungard bought them
02:39:45 <billf> the sc wiki has other details about sunguard
02:39:52 <alpo> https://steering.trilug.org/wiki/index.php/PhysicalServerAccess
02:40:36 <coxn> billf: it's Sungard: http://sungardas.com/
02:40:38 <billf> has anyone logged into our management portal lately ?
02:40:45 <coxn> I think Kevin has the login
02:40:53 <alpo> i don't know if anyone has EVER logged into the portal
02:41:18 <coxn> I think Kevin found it to be some IE-only thing that was rather worthless for us back when we first got access
02:41:26 <billf> so should I ask kevin more questions ?
02:41:27 <coxn> I don't know if he's kept his access fresh
02:41:30 <coxn> I can ask him, yeah
02:41:37 <coxn> or you can; whichever you prefer
02:42:08 <billf> coxn: would be great if you can chase this with kevin
02:42:28 <billf> which leads into the next topic if we are ready ...
02:42:40 <billf> #topic New Server Hardware
02:43:26 <billf> I can get more of these 1U dell servers. Maybe 11 of them
02:43:45 <alpo> woah!
02:43:53 <coxn> wow!
02:44:02 <justis> glossing over the complexity of it, I think the suggestion of providing virtual machines to other LUGs is fantastic. It's very much in the spirit of the original goals when TriLUG was founded.
02:44:23 <coxn> billf: that's awesome!
02:44:25 <billf> we can merge some together to make 2x cpu servers.  they are old, and pilot is better speed wise
02:44:26 <coxn> thanks!
02:44:34 <justis> billf: nice!
02:44:48 <alpo> speed is never an issue on these kinds of servers... it's RAM and disk
02:44:48 <coxn> I'll take distributed low-end over single point of failure high end any day
02:44:50 <billf> I have 2 here at home
02:45:44 <coxn> shall we start with a location other than Sungard?
02:45:52 <coxn> Peak10, maybe?
02:45:56 <billf> do we want to get together to build them up and instal them ?
02:46:10 <jeremyhwllc> OCt workshop
02:46:12 <billf> peak10 would be nice
02:46:19 <coxn> I'd be happy to do that, yeah.
02:46:20 <billf> I might not be her for oct
02:46:30 <coxn> November, then
02:46:44 <coxn> or you can leave them with me
02:46:47 <coxn> and we'll do October
02:46:52 <coxn> you pick
02:47:28 <billf> coxn: I will need a bigger car :-)
02:47:41 <jeremyhwllc> I gotta pickup
02:48:29 <billf> I can get you the two I have, and you can work out the install and serial console access
02:48:43 <coxn> :)
02:48:46 <coxn> excellent
02:48:53 <billf> I would like to help put them together
02:50:00 <billf> I'll email out more info when I get it...
02:50:04 <coxn> sounds good
02:50:06 <billf> shall we move to next topic
02:50:06 <coxn> schedule later
02:50:11 <coxn> sure
02:50:18 <billf> #topic reboot scheduled for Wednesday at 4pm that needs to be announced
02:50:28 <coxn> anybody have an objection to that time?
02:50:38 <coxn> if not, I'm going to send a notice to the list
02:51:18 <billf> I noticed that the Sungard announcements are very hard to read.  can we make ours communicate the intent better than they do
02:51:26 * alpo should be in the neighborhood
02:51:38 <billf> no objection to the time of the reboot
02:51:51 <jeremyhwllc> no object
02:52:07 <billf> coxn: can you summarise the reason for the reboot
02:52:21 <coxn> billf: lots of security updates over an extended period
02:52:26 <coxn> including three kernels
02:52:39 <coxn> I'd rather have a planned failure than an unplanned one
02:52:45 <billf> right, so include that line near the top of the announcement email
02:52:53 <coxn> okay
02:53:12 <coxn> #action coxn to announce Wednesday reboot on the mailing list
02:53:28 <coxn> shall we move on?
02:53:48 <billf> do we have a wiki page for server items that need to be worked on ?
02:54:03 <billf> which leads into ...
02:54:08 <billf> #topic Possibly non-kosher use of non-TriLUG domain for TriLUG service (planet)
02:54:30 <justis> o.O
02:54:35 <alpo> https://steering.trilug.org/wiki/index.php/Improvements
02:54:35 <coxn> so Tanner Lovelace runs a planet (aggregation of blogs) for TriLUG
02:54:44 <coxn> which is fine
02:54:50 <coxn> and he runs it on his own server
02:54:52 <coxn> which is fine
02:54:58 <coxn> but it's in the banner on our homepage
02:55:01 <coxn> and various other pages
02:55:13 <coxn> and it's not at all clear that you've left TriLUG and are now on Tanner's thing
02:55:21 <coxn> and that doesn't seem kosher to me
02:55:32 <alpo> (or that Tanner is donating his efforts to the LUG)
02:55:44 <alpo> (and that DOES sound kosher to me)
02:55:44 <coxn> and I'm not sure what, if anything, we'd want to do
02:56:07 <coxn> but I noticed this when I was confirming that updates I applied today hadn't broken anything
02:56:12 <coxn> since I updated php
02:56:37 <coxn> this was just not something I'd thought about before
02:56:38 <billf> would it be better if tanner ran it on our server ?
02:56:42 <alpo> i would not be offended if the "planet" link became less emphasized on our main site
02:56:57 <coxn> I'd prefer alpo's suggestion
02:57:18 <coxn> but I'd really prefer that whatever we do be a conscious decision by the group
02:57:29 <billf> the risk is that tanners site get's taken over, or he goes and joins a cult
02:57:41 <alpo> he's pretty clear about it on the main page - http://planettrilug.org/
02:57:51 <alpo> Planet TriLUG is not a product or publication of the Triangle Linux Users Group; as such, it does not necessarily represent the views of TriLUG as an organization.
02:57:55 <alpo> Planet TriLUG is powered by Planet and is run by Tanner Lovelace.
02:58:07 <billf> I propose that we re-design the website anyway, and perhaps include our own planet
02:58:33 <coxn> yes, but he's skinned it to look exactly like most of TriLUG
02:58:35 <billf> or at least deal with this topic when we do redesign
02:58:39 <alpo> there were lots of votes back in may for getting rid of drupal
02:58:40 <coxn> so he's working at cross purposes
02:58:58 <coxn> I'm cool with tabling this until a redesign
02:59:06 <coxn> since I think this is relatively low stakes
02:59:59 <billf> could we list the pros/cons for tanner running the planet ?
02:59:59 <coxn> so... do we want to schedule something to start tackling a redesign?
03:00:26 <coxn> billf: pro: he's been doing it since at least as far back as 2008?
03:00:40 <billf> So I think we get the new servers in with new OS, and then re-do the webpages
03:01:05 <billf> pro: we don't have to do anything to maintain it
03:01:25 <coxn> con: possible bus error
03:01:30 <billf> tanner is a trilug member, and is very reasonable to work with
03:01:44 <coxn> con: who has a "trilug" blog is entirely up to one member's judgement
03:02:02 <billf> pro: seemless integration (up to this point anyway)
03:02:07 <alpo> just like who @trilug "follows" on twitter
03:02:18 <coxn> oh interesting
03:02:24 <coxn> my blog used to be in the planet
03:02:27 <coxn> he's pulled it out
03:02:39 <billf> any idea why ?
03:02:43 <coxn> I wonder if he did that after I called him out in the comments on my blog
03:03:02 <billf> ahh, so this is personal (wringing hands in glee)
03:03:15 <coxn> I didn't realize that until just now
03:03:16 * alpo loves Tanner-bashing just as much as the next guy
03:03:19 <coxn> so maybe I should recuse myself
03:03:22 <alpo> but it's 11pm :-)
03:03:24 <billf> :-)
03:03:34 <coxn> yeah let's table this
03:03:51 <billf> so, anyway, the best way to deal with this is when we redesign
03:04:10 <jeremyhwllc> redesign at my house, I have a good setup for it
03:04:11 <billf> we can clean house (or not)
03:04:46 <billf> jeremyhwllc: can I bring the wife and baby ?
03:04:55 <jeremyhwllc> yup
03:05:22 <billf> ok, anything else tonight ?
03:05:37 <billf> we got through a lot tonight
03:05:43 <alpo> thanks for the lively meeting
03:05:58 <jeremyhwllc> for the next meeting would like to discuss video setup for meetings
03:06:05 <billf> jeremyhwllc: I have put up skeleton pages for the next 3 TriLUG meetings
03:06:30 <jeremyhwllc> rgr
03:06:33 <alpo> skeletons for Halloween
03:06:49 <coxn> haha
03:06:52 <billf> jeremyhwllc: can you get the Oct meeting announcement out this week (or weekend) ?
03:07:01 <jeremyhwllc> yes
03:07:36 <jeremyhwllc> probly wednesday
03:07:53 <billf> justis: have you calmed down from the weekend yet
03:08:08 <justis> billf: not entirely, but getting there
03:08:14 <justis> billf: do you need something?
03:08:22 <jeremyhwllc> sorry I missed the hack day. I was hacking on my truck
03:08:24 <justis> billf: btw, thanks for coming to see the exhibits :)
03:08:27 <billf> nothing at the moment
03:08:36 <billf> just ideas for next year
03:08:47 <alpo> we came by, too, but you were busy talking to someone
03:08:49 <coxn> we done with the meeting for tonight?
03:08:50 <justis> ideas for TriLUG or for SPARKcon?
03:09:01 <billf> sparkcon is around the same day as Software Freedom Day
03:09:07 <justis> alpo: thanks also for coming by :)
03:09:17 <justis> billf: oh, neat
03:09:17 <billf> #endmeeting