17:30:34 <billf> #startmeeting
17:30:36 <Tribot> Meeting started Mon Dec  2 17:30:34 2013 UTC.  The chair is billf. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:30:37 <Tribot> Useful Commands: #action #agreed #help #info #idea #link #topic.
17:30:47 <billf> #chair coxn mhrivnak billf IsharaComix justis
17:30:48 <Tribot> Current chairs: IsharaComix billf coxn justis mhrivnak
17:30:56 <billf> #topic Meeting 12 December x-mas party
17:31:27 <billf> let's talk about promotion ...
17:32:04 <mhrivnak> how many people usually come to this?
17:32:22 <billf> last year we have 30 - 40 people I think
17:32:30 <mhrivnak> cool. I'll try to recruit some demos.
17:32:35 <justis> 30-40 sounds right
17:33:27 <billf> we have 9 people signed up so far.
17:34:00 <billf> I need someone to copy the demos from the response spreadsheet into the drupal page
17:34:26 <billf> make it look pretty - some have provide urls or graphics
17:34:51 <justis> I need some text for this: http://www.meetup.com/splatspace/events/149113952/
17:34:58 <billf> and then we should push for more sign-ups for food, etc
17:35:00 <justis> then, we can cross-promote via their meetup
17:35:00 <mhrivnak> FYI: looks like "vegetarian" is misspelled on the form.
17:35:35 <billf> justis: can you link back to the trilug weboage ?
17:35:43 <justis> yes
17:36:06 <billf> I promoted it on the Durham Lug meetup last week
17:36:08 <justis> I made that page a month ago, before we had a page on trilug.org
17:36:35 <billf> so now we have two meetup pages :-)
17:36:53 <billf> volunteer to do the drupal page edits - please ?
17:36:55 <justis> should I just copy http://trilug.org/2013-12-12/demo verbatim?
17:37:38 <billf> justis: that was the best I could come up with at the time, and nobody edited it :-(
17:37:45 <justis> ok
17:38:03 <mhrivnak> I suck at making things look nice. perhaps IsharaComix, our PR person, can take care of it?
17:38:18 <billf> IsharaComix: what say you ?
17:38:54 <billf> #action IsharaComix will update the Dec Drupal page with the current demos from the sign up form
17:38:59 <billf> Catering !!
17:38:59 <IsharaComix> Sure, I can.
17:39:17 <IsharaComix> Drupal editing makes me ;_; though. :)
17:39:42 <billf> coxn: can you org the catering again this year ? we will have a budget by next Monday
17:40:30 <mhrivnak> coxn, feel free to bring me in when it's time to pay for it.
17:40:32 <coxn> I can place the order, sure
17:40:38 <coxn> mhrivnak: appreciated
17:40:55 <billf> anything else on this topic for today ?
17:41:13 <billf> #topic Meeting 9 January & 13 February
17:41:26 <billf> we need a speaker or two :-)
17:41:45 <mhrivnak> do we have any irons in the fire?
17:41:58 <coxn> there was no action item for me
17:42:11 <coxn> #action billf to get a catering order to coxn
17:42:20 <coxn> #action coxn to place catering order
17:42:31 <billf> I'm going to be tied up with a new baby, so I am asking now for someone to take on my responsabilities ...
17:42:37 <coxn> I haven't heard back from the percona guy
17:42:44 <coxn> about a 5.6 talk
17:42:48 <coxn> not sure what's up
17:43:11 <mhrivnak> billf, so we need an emcee, and someone to film it?
17:44:16 <billf> I could be avail, or not on the night. I probably won't have the brainspace to org IRC meeting etc
17:44:55 <billf> I'm going to ask on IRC and mailing list for speakers
17:45:14 <mhrivnak> I'm happy to emcee if nobody else would like to.
17:45:31 <billf> #action billf will put out a call for speakers for 2014 on the ML and IRC
17:45:31 <billf> #topic 501(c)3 Application
17:45:32 <mhrivnak> and I suggest we try to find someone not on the SC to do the webcam work.
17:45:38 <billf> doodle poll results ?
17:45:56 <mhrivnak> mon 12/9 at 7:30 works for everyone.
17:46:03 <mhrivnak> sunday afternoon 12/15 works too
17:46:18 <billf> #action billf will ask for a volunteer to video Jan and Feb
17:46:24 <justis> can we do 12/15 instead?
17:46:32 <mhrivnak> Sunday would be more convenient.
17:46:39 <coxn> let's do that
17:46:56 <mhrivnak> 2, 5, and 7pm were all green. or we can go somewhere in between.
17:47:57 <coxn> mhrivnak: pick your favorite and send an invite?
17:48:22 <billf> #action mhrivnak will send an invite for Dec 15th F2F meeting
17:48:37 <billf> #topic Sunguard and Linode replacement
17:48:52 <billf> coxn: want to give us a status ?
17:49:23 <billf> coxn and jack have been working over the weekend on this
17:50:43 <justis> Have we gotten any response from Peak10?
17:50:49 <billf> nivex just sent an email to the SC, Sunguard wants action
17:51:06 <coxn> back
17:51:11 <coxn> we have a VM
17:51:15 <billf> nothing from Peak10, but give them a few days to process it
17:51:15 <coxn> it has apache2 up
17:51:19 <coxn> and it has mysql
17:51:30 <coxn> and we're working on loading a dump from pilot
17:51:35 <coxn> and getting a drupal install that works
17:51:46 <coxn> if others want to help, we should meet in person and have keys set up
17:52:03 <coxn> alternatively you can spin up your own VM somewhere and migrate some portion of what's on pilot
17:52:04 <billf> so if Sunguard shuts us off today ?
17:52:08 <coxn> and we just coordinate
17:52:16 <coxn> we have backups
17:52:22 <coxn> and we'd have an outage but we could get back up
17:52:57 <billf> should we build a vm with the pilot backup to get web and mailing lists running ?
17:53:04 <coxn> that's what we're doing
17:53:26 <billf> I thought you were re-building new services
17:53:34 <coxn> what I'm saying is that if somebody wants to bite off a subset of pilot's roles and put *that* on a separate VM I'd be interested in hearing from people
17:53:51 <coxn> I have no idea what you mean by that
17:54:16 <coxn> I understood the task to be stand up the drupal instance and mailman on a new node
17:54:31 <coxn> and I started working on that with Jack, and we tried to do it as "right" as possible
17:54:43 <coxn> so that we would not have huge headaches untangling things later
17:55:07 <justis> @coxn++
17:55:12 <coxn> ldap is still broken, but we've been working on things in parallel
17:55:33 <coxn> so right now we have various things in-progress
17:56:19 <coxn> and if people are uncomfortable with the pace of our progress, then I suggest people stand up other VMs and we put some portion of what's on pilot on that
17:56:29 <coxn> otherwise we'll keep updating in #trilug-sys
17:56:50 <justis> I'm very happy wit the pace of progress and regret that I cannot help.
17:57:25 <coxn> if people need my help standing up a VM, then I suggest we meet in person
17:57:31 <coxn> and people can reach out to me about meeting up
17:58:00 <coxn> I estimate I've spent about 16 hours on this so far
17:58:08 <justis> wowzas
17:58:38 <coxn> yeah. the 2.3 -> 2.4 openldap is a mistake
17:58:43 <justis> :(
17:58:43 <coxn> and we'll be replacing that
17:59:02 <coxn> but anyway... what else do people want to know?
17:59:17 <coxn> should we talk about how we want to engage Sungard?
17:59:59 <justis> re what else people want to know, we should probably keep a list of what hasn't been moved
18:00:06 <billf> we might have pull hardware out today or tomorrow
18:00:44 <justis> Kevin can probably buy us some time, maybe a week or two, if we tell him what to ask for
18:01:21 <justis> our Sungard contact probably just needs to tell his team something final, e.g. "they'll be out by Dec 10"
18:01:25 <billf> Kevin is going to run delaying tactics, but they seem pretty insistant, and we want our hardware, right ?
18:01:35 <justis> yes, we want our hardware
18:01:55 <justis> are you thinking we should go retrieve it while we still have access and they think we might sign a contract?
18:02:15 <billf> yes, before they lock us out for good
18:02:21 <justis> hrm
18:02:33 <billf> kevin is unemployed and is willing to go retrieve it
18:02:39 <justis> do they have any legal grounds to keep our hardware?
18:02:44 <coxn> well then somebody should be on a separate track of finding a place to put it
18:02:51 <billf> he might be able to stand it up at his home for a week or so
18:02:53 <coxn> not me: I'm focusing on standing up VMs
18:03:01 <justis> coxn: good choice
18:03:09 <billf> should we pull the hardware today ?
18:03:12 <coxn> then lower the TTLs on pilot and related now
18:03:26 <billf> TTLs are 2 hours
18:03:29 <justis> billf: if Kevin wants to run it from his house, that technically buys us time
18:04:00 <coxn> billf: yeah, and that should be lowered to 5min now if it's going to change
18:04:13 <billf> coxn: good idea
18:04:30 <justis> for how long has Kevin been unemployed?
18:04:36 <billf> no idea
18:04:41 <coxn> a few months
18:04:45 <justis> bandwidth.com is hiring and he'd be a good fit there, imo
18:04:53 <coxn> you should talk to him
18:04:55 <justis> ok
18:04:57 <coxn> but... later. :)
18:05:14 <billf> Are we OK with an outage if we pull the hardware today ?
18:05:19 <coxn> okay... anything else on infrastructure changes?
18:05:25 <coxn> I certainly am
18:05:32 <coxn> anything < 4 hrs is not a major issue
18:05:33 <justis> I'm fine with an outage
18:05:48 <coxn> because SMTP is magic
18:05:49 <coxn> :)
18:05:50 <billf> I will send an email to the ML now to warn them
18:05:51 <justis> anyone who isn't fine with an outage should have volunteered for our systems team by now :p
18:06:06 <coxn> billf: hold off a sec... we haven't confirmed Kevin can host at home
18:06:12 <coxn> billf: or did you already confirm that?
18:06:35 <billf> no, we have no confirmation of hosting it
18:07:27 <coxn> I'm asking in #trilug-sys
18:07:28 <billf> this could be a major outage !
18:08:03 <coxn> 13:06:51 < Nivex> *if* I can arrange the public IP space, which has not yet been confirmed
18:08:11 <coxn> 13:07:39 < Nivex> query has been vollied, waiting for answer
18:08:29 <billf> ok, so what do we do now ?
18:08:43 <coxn> is there another place that can host that somebody can call this afternoon (ie. in the next couple of hours?)
18:08:47 <billf> pull hardware as soon as the public IP space is granted ?
18:08:54 <justis> I'm gonna call Craig Isdahl at DASH Systems
18:09:09 <coxn> announce as soon as a place to put the hardware is confirmed and Kevin has confirmed a time to move the hardware
18:09:13 <billf> I can host servers, but I don't have any spare public IP
18:09:15 <coxn> @justis++
18:10:10 <billf> Hmm, maybe kevin was talking about hosting DNS and a "page is down" webpage
18:10:32 <coxn> again, I think additional VMs are an option
18:10:45 <coxn> they cost US$, but relatively little time/energy
18:10:54 <coxn> and it's $20/month/vm
18:11:15 <coxn> and this is a big hairy mess of discussion
18:11:25 <billf> what about alan's suggestion of just dumping the backup into a vm on linos  ?
18:11:56 <billf> linod ?
18:12:02 <coxn> linode
18:12:03 <billf> linode ?
18:12:13 <coxn> I don't really know what is meant by that idea
18:12:23 <billf> I will ping alan about it
18:12:38 <coxn> but based on one guess, I'd estimate about 4 hours to get some subset of services working
18:12:49 <coxn> and then you'd have a hairy mess to migrate off of later
18:13:02 <coxn> so who knows how many hours that'd be
18:13:23 <coxn> but if that stresses people out less, then I can stand up another VM and somebody can have a crack at that
18:14:11 <coxn> again, people can reach out to me to stand up additional VMs and we can meet up
18:14:20 <coxn> okay we're hitting our time limit
18:14:25 <justis> we have 3U worth of stuff, right?
18:14:28 <coxn> and I need to get walking to another meeting
18:14:30 <coxn> justis: correct
18:14:32 <billf> yeah, I will ping alpo
18:14:33 <justis> thx
18:14:41 <coxn> justis: well... 4U if you include our switch
18:14:42 <billf> ok, more via email later today
18:14:54 <justis> I got no answer from DASH, I'll email
18:15:04 <coxn> thanks justis
18:15:22 <justis> I'm asking him for temporary space, to simplify our transition
18:15:26 <justis> how long do we need?
18:16:21 <billf> justis: I don't know, a few weeks ?
18:16:31 <justis> that's what I was thinking
18:17:32 <coxn> justis: maybe say 20 days to be sure?
18:17:46 <coxn> okay I have to run. y'all can keep going or close this out
18:17:51 <coxn> but I'm stepping away
18:17:58 <coxn> ciao! thanks!
18:18:12 <billf> bye
18:18:16 <billf> #endmeeting