[TriLUG] Linux forums other than trilug?

Rock Roskam Rock.Roskam at sas.com
Thu Sep 9 09:00:48 EDT 2004


They have helped me in past.

Rock R

-----Original Message-----
From: trilug-bounces at trilug.org [mailto:trilug-bounces at trilug.org] On Behalf Of Tom Bryan
Sent: Thursday, September 09, 2004 8:34 AM
To: trilug at trilug.org
Subject: [TriLUG] Linux forums other than trilug?

So, I've posted about this question a couple of times, and it looks like everyone's as stumped as I am.  I'm just about googled out.  What other high quality (high signal-to-ratio) forums do you all use when TriLUG can't answer your question?

In case anyone wants to take a crack at the original question, I'm having trouble with grub and a wrong kernel image version number.  I wanted to move my root partition, which contains both / and /boot to another hard drive.  

> > Boot knoppix or equivalent, and mount the old and new partition.  
> > It'll go faster if the two drives are on different IDE channels.
> >
> > cp -avx /mnt/old/* /mnt/new/
> >
> > I suggest reading the man page to see just what those flags are doing.
> Thanks.  That seemed to copy everything, but do I need to do something  
> special with the kernel image?  Or am I forgetting something silly?  
> I'm  getting the following error in grub
> kernel /boot/vmlinuz-2.4.20-8 ro root=/dev/hdb1 Error 15: File not 
> found
> /dev/hda8 was my old root partition.  /dev/hdb1 is supposed to be my 
> new root partition when I'm all done.  grub.conf looks like this on 
> both
> partitions:
> default=0
> timeout=10
> splashimage=(hd1,0)/boot/grub/splash.xpm.gz
> title Red Hat Linux (2.4.20-8)
>         root (hd0,7)
>         kernel /boot/vmlinuz-2.4.20-8 ro root=/dev/hda8
>         initrd /boot/initrd-2.4.20-8.img title Red Hat Linux (2.4.20-8 
> new hard drive)
>         root (hd1,0)
>         kernel /boot/vmlinuz-2.4.20-8 ro root=/dev/hdb1
>         initrd /boot/initrd-2.4.20-8.img
> /boot/vmlinuz-2.4.20-8 was copied using cp -avx from /dev/hda8 to 
> /dev/hdb1 (while they were both mounted from using Knoppix).  I ran 
> rdev to switch
> /boot/vmlinux-2.4.20-8 on /dev/hdb1's root device to /dev/hdb.  

That's it.  :-/  I copied all of the files from one partition to another (when they were both mounted under Knoppix) and tried to boot.  The file really is
/boot/vmlinuz-2.4.20-8 when I mount it under Knoppix or my initial hard drive (hd0,7).  Grub is the only thing that seems to see all of those (System.map, vmlinuz, initrd, etc.) as 2.4.18-3.  Where does it get that number?  If I change grub.conf to say that the kernel on (hd1,0) is vmlinux-2.4.18-3, then grub will try to boot it, but then it can't find /lib/modules/2.4.18-3/, of course.  Ugh!

I'm just about to report a bug in grub because I can't figure out how else to determine where 2.4.18 is coming from.


TriLUG mailing list        : http://www.trilug.org/mailman/listinfo/trilug
TriLUG Organizational FAQ  : http://trilug.org/faq/ TriLUG Member Services FAQ : http://members.trilug.org/services_faq/
TriLUG PGP Keyring         : http://trilug.org/~chrish/trilug.asc

More information about the TriLUG mailing list